Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Twitter

BaseV2 Drum Sequencing?

So I'm using Bitwig 1.3.16 with a Livid Base V2. MOST things seem to be working how I'd expect them to, but one or two things are really distressing me.

As per the tutorial videos on YouTube, I'd like for the Base to switch to two grids of 4x4 when I go to a drum machine track, so I can select sounds on the one side and sequence them on the other. Seeing this working in the video is precisely why I bought the thing... anyway - mine seems incapable (read: I seem to be incapable) of making it enter that mode at all. It has another mode which is two grids of 2x8, which is I guess intended for step sequencing just in a different orientation, and that's the only one that ever appears. There doesn't seem to be any way of setting up BitWig into making it mimic the behavior in the video, nor does there appear to be any button presses in any combination that will coax that mode out of the Base.

My firmware is up to date, I've tried a factory reset numerous times, the cables are fine... am I missing something?

Please help! Thanks very much in advance.


  • I'll have a look and get back to you when I can, but I think you probably just need to manually assign the "DrumPad" scale to that track.....anyway, it's doable.  I'll get respond again when I get in front of a Base and Bitwig if you haven't figured it out by then....


  • Everything is working fine for me.  You need to be in mode 4 (function buttons on the right side of Base), and if you're not using one of Bitwig's built in DrumMachine devices, you'll probably want to manually change the scale setting by holding down shift (again, function button for selected mode 4 on the right) and using the scale change buttons (above fader 5 and 6) to set the scale type to DrumPad.  It's the very first scale, so if you scroll down as far as you can go, you'll have the right one.


  • Hi! Thanks very much for the reply! I really appreciate your instructions being quite thorough, too.

    Yup, this is with creating a new dedicated drum machine clip in a track which only contains a drum machine and nothing else - none of the native drum machines seem to activate it, nor does a blank drum machine. Oh, in any mode too (Arrange/Mix/Edit), whether playback is looped or not, regardless of the type of track the clip is in, or whether there is a clip or not.

    So, the first scale for me, regardless of what kind of track/device is being selected is just 'Chromatic' - I don't even have the 'DrumPad' option for a scale - I've gone through all of the scales a few times now just to make sure I'm not missing it, but yeah, it looks like that's not available at all.

    Would it be rude to ask if I could see your preset file? Or perhaps your BitWig scripts for the Base2? I'm coming fresh from factory resets and all the 'latest' files according to the site, I can only really think that perhaps it's that there's an issue with what's on github currently?

    I still hope I'm just being stupid and it's something I've overlooked...

    Thanks again for your help so far!

  • Update! After performing a series of superstitious rituals with disconnecting and reconnecting the device in and out of BitWig, I managed to get it working. I switched BitWig's preference from Base 2 to Base 1, then restarted the computer and BitWig into this setting, then, after the Base had loaded up, deleted the controller from the preferences within BitWig, then let it auto-detect, at which point it brought up the Base 2 with all the correct routing.

    This seems like such an odd way to have got it working - this is a new USB cable, but I wonder if it might be that? Anyway, for now it looks like my problem's been solved. However, I'm still a bit concerned it might decide to go back to how it was and perhaps the stars won't align correctly next time I try the same ritual, so if you can think of any other reason why Drum Pad mode might have become unavailable to me, please let me know!

    Thanks once again for all the help, really appreciate the effort.

Sign In or Register to comment.