Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Twitter

BASE II FSR pad sensitivity issue.



  • Yheyy, 

    I am looking forward to the results of that :)
  • This will be the last chance for me, hoping this is not only hardware related... While you say the Base seems to work for many users, I noticed that, like the Quneo from another manufacturer, the videos don't underline the playability of the pads, and in those demos, people don't do subtle stuff with the pads but rather hard hitting them to be sure it's going to work. If some user can testify in that sense, I would appreciate it.

    > Moon said: > Hi madlab,

    While both the Base and Base v2 have worked well for a great many of our users,
    we take your dissatisfaction very seriously, as we strive have everyone love each and every product.

    We are working hard to get the FSRs to respond more consistently to lighter taps and those quick 'swiping' style hits, such as you displayed in your video.

    Currently we are focused on maximizing speed and consistency of the scanning.
    So far we have rewritten much of the FSR scanning code in Assembly Language, and using the saved overhead to ensure that the FSRs are scanned as frequently and consistently as physically possible.
    From our results thusfar, we know this will improve the FSR performance at least some.
    We are testing and debugging this code currently, and we will continue working on it over the next week or two.
    I will post here when we have a beta grade firmware build to share.


  • edited December 2015


    The original assignment of autowrite toggle was to the project setting, not the clip setting.  The latter is the more desirable functionality in my opinion.  I recall now (after messing with it a bit) that the reason we did this in the original script was because there was (and still is) a bug in the API which prevents the status of clipautowrite being reported from BW, and that's why the LED doesn't update properly.  I've made the change to enable clipautowrite instead of autowrite because I, also, feel that it's the best use of that button, but you won't get the correct reading on the led until BW fixes their end of things, sorry.  

    Regarding the instrument sequencer:  this, again, is a problem with the API.  Our script relies on knowing what the currently selected device is (more specifically:  whether it is a drum rack or not), and for some reason in the newer versions of BW, the API doesn't report that value correctly.  My experience is that sometimes it works, sometimes it doesn't (depending on whether BW gives us the correct data about what's selected).  I reported this to their support over a month ago and I haven't heard anything back, but hopefully they are working on a fix.  Most of the time when I select a track I get the right response from the API, but sometimes it doesn't work and I can absolutely confirm this is a problem on their end.  There's not anything I can do about it until they fix it.  As you probably already know, this used to work fine but along the way somewhere they broke that functionality.  When these things happen, unfortunately all you can do is download an older version, wait patiently, cross your fingers, and make the appropriate amount of squeaking towards those that possess the proverbial can of oil.  Unfortunately, though, in this case I am not the one holding the can.

    I've made some other tweaks to accommodate groups (basically just turned off the clip autoselect for group channels) but as far as I can tell, there aren't any API hooks that allow firing group scenes via the clip grid.  I might just be missing something here, but I was pretty thorough.  There are also incongruities with their implementation of these new features that don't jive with the published literature, so I'm stuck waiting for them to reply to my complaints and either explain themselves better or give me a new version that works properly.  It's my suspicion that they haven't completed their groups implementation in the API, and we may see better possibilities in a future version that is more robust.   In any case, I'll keep you updated as I learn more, and I will push my latest changes to github tonight for everyone to check out.  Please let me know if you find any new issues (I hope I didn't break anything!), and thanks for the help and patience :)

    edit::  I haven't forgot about polyphonic aftertouch, but I have to get these other issues sorted before I can make any major additions to the scripts that could be impacted by how I'll need to deal with fixing the current problems.


  • @amounra

    hey this is my first time posting, been watching this thread for a while though. I myself emailed bitwig a few weeks ago and asked if there was any update to the drum machine issue and they said "were working on it"
    i have been able to make the drum machine usable though by setting the vertical offset to 8 while on page 4.
    Also is there anyway to enable the color coding of the pads in clips mode? I noticed the wil marshall base script for ableton had this enabled, and many other bitwig scripts you can choose the clip color, this works on the push, the apc40 and I am sure a few more. is it just something that needs activated?
    and one last thing... is it possible to enable pad sensitivity when programming drums into the step sequencer? 
    thank you so so much for all the hard work you have been putting into this script, just installed the latest repo 
  • @amounra : any news ? The Base is still unusable for me, and I think it's the same for users hoping to do fingerdrumming with it. May I remind you that I got a kind standard exchange of my first unit by SCV and that the second one suffers from the same flaws. I feel ashamed thinking I should sell this brand new unit being defective. I feel like an asshole having spent more that 350€ for such useless plastic junk.

  • @amounra Happy new year! Thank you very much for the detailed news and your work on the script. The API changes must be annoying but it is partly a problem because of us users that were asking for a lot of features before they would be "able" to buy their product. Now we have a lot of features but also a lot of bugs to be fixed.

    I really like the idea of ronaldnicol89 to implement velocity in the step sequencer btw. I am also using the Nektar Panorama, where they implemented this using the faders to set velocity of the single steps. However you have to switch on and off the steps in order to update any velocity changes. But it is a very cool feature though. What I also like a lot is that you can create new empty clips with a set length in that script. That is very helpful because the default on bar length is very limiting and going for the mouse each time destroys the hardware experience a bit. Maybe you could have a look at their script also because their sequencer works reliably with drum machines and synths so somehow they set it up differently I guess. If you are interested I can send you the script.
    I am happy to hear that you are still considering the Polyphonic aftertouch as well since none of my other hardware products supports that. Have a nice day and many greetings from Berlin, Ulrich
  • I'd like to suggest that further posts about the API / script issues be placed in a new thread so that this one can focus on the FSR sensitivity issues it was originally opened about.

  • edited January 2016

    Guys, It's the author of the thread here.

    After I don't know how many attempts I somewhat found out the solution. 
    (I sended the controller even back to the mother base for checking the problem without results)
    The problem is the space between the rubber pads and the FSR resistor sheet. I added in between 2 foil of nylon wrap (You can add even 3 for maximum sensitivity).
    Now it's ultra sensitive.
    I almost cryed when I saw that it worked. 
    You all owe me a beer. 

  • @PolloRapido : I mentioned this trick in another thread to Livid because I suspected this kind of design flaw, as found on the akai mpd a few years ago.
    About the beer, I would say that Livid owes a beer to all Base users. These are expensive controllers and several of us tried to get Livid to acknowledge there is a hardware problem. So sad they didn't do it...
    @amounra or anyone else at Livid ? Any comment ? Any solution ?

  • I only work on the software end of things.  The issues referred to by the OP are firmware or hardware related....that's why I haven't commented on them.  I'm not trying to be evasive, I just don't know a solution for you.  I'd say that if there is a solution out there that will solve the problem easily (@PolloRapido), sounds like a good place to start.


  • @amounra Thanks for replying. I mentioned your name just because you commented on previous topics. I just regret that someone in charge of the hardware part doesn't find time to adress those concerns. Also I find it weird to have to open a brand new high end controller to correct a design default and am concerned by the fact that the warranty will be dead because of me opening and modifying a product that was bought new, exchanged by the seller, and not used for nearly one year now because it's defective. As I wrote, I mentioned Pollo's trick in a thread mid 2015, as found on an akai forum many years ago, but noone seemed to care at Livid, just pointing me to software (non) solutions.

  • Seriously guys? I am currently selling my Akai MPK25 because of the same issue and replaced it by the BaseII…

    I also read those tips about fixing it by putting some plastic sheet below the pads. As it turned out it is not as easy as it sounds to find something that works properly to fill the gap between the pads and the casing. Because it has to have the right viscosity and size. When I did it in the Akai I found I could trigger the pads more reliably but the aftertouch was broken in some pads because it got constantly activated. I used different materials and even casted some silicon film myself at the lab I worked at that time… I the end the screws that fix the frame which holds the pads got more and more lose. So I stopped experimenting before I break it.
    With an instrument as expensive as the Livid Base, I think it would be Livids turn to send the users a kit that allows for an easy fix. Especially since their quality control only managed to fill out the paper that comes with each sold unit, but failed to detect that problem. You really have to hammer on the pads to trigger them. That is something you can spot very easily!
  • @PolloRaipdo btw what exactly is nylon wrap? The stuff you use to cover food for the fridge? That was another issue with the tips from the Akai forum. They would use materials you do not get easily elsewhere than the US. so one would have to guess from some pictures what type of material it could be and what to use instead…

  • @quasimono : "With an instrument as expensive as the Livid Base, I think it would be Livids turn to send the users a kit that allows for an easy fix. Especially since their quality control only managed to fill out the paper that comes with each sold unit, but failed to detect that problem. You really have to hammer on the pads to trigger them. That is something you can spot very easily!"
    As you could guess from my previous posts, I completly agree with this statement.
    @amounra (nothing personal - just that somenone from Livid taking care of HW should answer :))
    Can somenone from Livid react to that statement ?

  • Really happy to hear that. This kind of feedback is really important to us users to feel not being left alone. Hope that you can find a solution soon and that it will be possible to implement a fix on our hardware as well. Enjoy the weekend!

  • @quasimono I used exactly the food type plastic wrap aka cling film (I used that because it's clear and slightly viscous)

      The irony is that someone left the hardware design in the oven for too much and we have to use the wrap to "save" it. BTW. @moon I'm thirsty. ;) 
  • @PolloRapido Does aftertouch still work on all the pads? How fiddly is the whole process? I mean you have to cut 32 square shaped pieces twice to have two layers of the foil and then you have to secure them somehow so they dont slide aside while you reassemble the whole thing again. I imagine this could be quite annoying to do…

  • @quasimono I'm assuming he laid a single piece out across the whole pad bank. I recall doing something similar to a PadKontrol years ago (though that started out much more responsive in the first place).

    I would think that a sheet of mylar could work as well as it is metalized and therefore conductive (I think?)

    @moon thank you for the feedback, it's good to know you guys are addressing this. I like the idea of this piece of hardware but have found very little use for it in production and live performance due to this very issue. Please keep us posted.
  • @quasimono It's super easy, I just laid the pieces (I used two)on the fsr resistor sheet, and punched few holes for the screws, it won't moves at all when you reassemble it. The aftertouch works fine. The whole process takes about 10 minutes. NOTE: don't you ever over tighten the screws or you're gonna have a bad time.

  • @PolloRapido thanks! I gonna try it like this soon and will load up the pictures of that process for everyone to see. If I understood you correctly you just cover the complete set of 32 FSR resistors at once with two layers of foil. Nice :-)

  • Cling film is thick enough ?

    @moon you wrote "So, they are working on this now, by building a few units to test and perfect this enhancement, and presuming it's successful, we will quickly work out how to provide it. I should have more news on Monday after their tests have completed."
    It's thursday now. Any news ? cling film seems a bit cheap and fragile to me...

  • @madlab  It's been two weeks since I applied the film, and I used the base approx 1hr per day (I even got 4 gigs this weeks). It's still working, and I think it will for a lot, zero doubts about it. IMHO Maybe it's about the quality of the film that you have, and about the thickness, the gap between the rubber pads and the fsr sheet is very very short, keep in mind that on the box of the film that I use it says that it has a thickness of 23 µm (Yea yea, metric system... I'm in italy btw).

  • Hmmmm OK, i tried that mod and it did not work for me. Right now the pads don't trigger at all. The are still illuminated though. Here are all the steps I did and a stencil to cut out the sheet to put in between pads and FRS sensors @PolloRapido Maybe you can have a lock to see if I did something wrong?

  • Sorry the link seems to be broken here another one

  • Ok.

    I learned today what an isolator is. Doh!!!
    So I actually put the foil between the parts of the FSR sensor instead of in between the pads and the sensor hahaha. It works as expected now. It is still not comparable to the NI machines I played at some friends place but it is quite decent now. So it is really a hardware problem as PolloRapido already said. If you want to try it out yourself just take plastic wrap fold it using a ruler as help so it does not get too wrinkled. Fix it with a stapler on top of my a printout of my stencil file and cut it out using a boxcutter. Cut the holes for the screws as well with a boxcutter. Don't worry they do not have to be round. Just cut little squares. Dissemble like shown in the pictures and don't forget to take away the everything until you see the rubber pads. Put the plastic wrap and put everything back together. Here a link to the whole process. And a video of the performance improvement.

  • The video had no sound and is therefore useless. Here is one with audio working

  • Thanks for the uploads, quasimono. It's great if it's improved things for you. Personally I'm a bit perplexed cause mine plays pretty much like that now, without mods; yet I'd still like it more sensitive... Anyway a quick question for you:

    On the video at 00:09, pad 3 plays a flam/double-hit. Can you recall if you hit the pad twice, or is that an unintended retrig? It also sounds like a very fast double-hit on the next snare (pad 2) too, around the 00:10 mark.

    I'm curious if the greater sensitivity does anything to improve (or worsen) such stutters - as I do encounter lots of momentary note off which cause unintended retrigs (often more glaring when softly sustaining key sounds).

  • Hello lowshelf I am using Battery4 and am using some modifiers like release stroke (first hit on push second on release). So actually it is not stutters but me lifting the finger a bit too quickly. I am using a setup with two hi hats, the off-beat one a bit less loud. Four snares, one of them for ghost notes, one normal, one release stroke and one buzz. I also have some open hats, double kick etc. I made another video where i also use the sends, some makro and clips triggering and recording. Its not perfect, but I did not touch my BaseII for almost a year now. I am pretty happy that its working as a proper controller now…

  • @quasimono With one wrap it's ok, but I used two layers of it, and it's just perfect. (I'm having problems downloading the .zip, later at home I will retry)

Sign In or Register to comment.