Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Twitter

Brain Jr Buttons Not Working

edited June 2014 in Hardware

Hey, I just got my Brain Jr pack with the 2 OmniRGB boards, 16 buttons and 16 knobs. I got the knobs working perfectly but the buttons seem to not register. I tested things out by making sure there was current with an led, when I connect the outer and inner ring the led lights up super faintly but no press is triggered in the config tools. I'm not quite sure what could be wrong as there is current on the board and I tried out a bunch of different settings in the config.



  • The button and LED circuits are completely separate, so let just talk buttons for now.

    Your set up should be the most basic, Omni RGB board connected from the button header on the omni, down to the button header on the Brain Jr.. Be sure that the pink wires are matching up to the white arrows.

    This should work with default settings. The LED feedback won't be correct with default settings, but you can see that when you press a button, the note message is sent. What are you using to press the button?

  • edited June 2014

    I wasn't doing anything with the space for the on board leds, I was using an led to touch the button connectors to make sure the board has power. The pink lines are matching the triangles and I also tried to press the buttons with the proper part first but that didn't work at all. Also when I connect to my computer and run Brain V2 Configure it sometimes doesn't pick things up even after clicking the red box (which is odd as BrainJr shows up in the controller drop down list and the knobs work in various programs)

Sign In or Register to comment.