Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Twitter

drumstepp-r not working properly with -CNTRL:R


When I load a DrumStepp-r in a blank midi track (Ableton 10), then the sound/sequence control dials (like ADSR and such) only show up in a split second and then dissapear.
When I follow the instructions of the tutorial video, this also does not bring up these functions to these dials.

Does somebody recognizes what the issue could be here?
It's frustrating, as I can not use the controller like it should. Followed every step very carefully, installed everything according to instructions, but still, the dials won't show up with their functions.

Also, I can't figure out how to reach the drumrack and step sequencer via the CNTR:R. 
Which dial activates the drumrack, and which dial makes the leds active on the sequencer of the controller?
Is there some kind of system, map or anything? Can't find any documentation about that.
When I follow the exact same instructions with any video or tutorial, my controller just doesn't show the step sequencer in the 16row leds...

Do i need a reset or something?

Any help would be much appreciated as I have some shows coming up and would love to be able to use this.

Thank you!


  • I did some work on this recently, so I know the issue you're talking about.  Thought I'd fixed it though.  Have you downloaded the most current version of m4m8 and installed it correctly?


  • Hello Amounra,

    Thank you for your quick reply.
    Yes, it was installed via m4m8, alltough, yesterday I tried with a different installer, because the one with the m4m8 didn't work for me.

    Another thing I noticed today during troubleshooting:

    If I disable the CNTRL:R as control surface in the midi prefs of Ableton, then the ADSR and such do stay active on the Steppr (didn't fully check if it works, because I just noticed this)

    So the fact that the CNTRL:R is active as control surface, prevents the Steppr to work properly.
    Is this info that rings a bell? I'm thinking I installed the scripts wrong, but I really followed every step in the instruction, so, don't know what I've could have done wrong.

    Do I need to uninstall and reinstall something? 

    It would come in very handy if I can use it as a controlsurface as well.

    Looking forward to your suggestions.


  • edited September 2018

    Some more infomation that might be useful:

    If I select for example the Livid DS1 as a control surface, then the ADSR and such also stays active.
    So the problem has to be linked with the 'Liviid cntrlr:r v2' script (also same issue with the retro script).

    Even if the controller is not physically connected, the adsr dissapears the moment cntrl:r is selected as control surface.

  • And another update Amounra...

    I'm afraid its getting worse.
    After I updated Ableton to the latest version (10.0.2) as requested in the readme files for installation of the control surface, and after I installed everything exactly as asked in the readme...
    unfortunately, not a single Livid control surface shows up anymore in my drop down list in the midi prefs.

    It's becoming really frustrating, because I'm losing days of precious studio time to troubleshooting.
    It should'nt be that difficult isn't it, to simply plug and play a midicontroller?

    Can you please help me out on this?

  • also weird is that every other folder that is added from the m4m8 folder is visible in the dropdown list in Ableton (such as aumhaa, monopedal, debug etc...)

    Only the Livid folders with the controllers are not showing up.
  • Have you tried with the current version of Live (10.0.3)?  The current version of m4m8 is built against that version, I'll change the readme to reflect that.


  • Hello Amounra,

    I have updated just now, to version 10.0.3. Then I downloaded the m4m8 again from the git.
    Then I've installed the drumstepp:r with the automatic installation thing, because I can not find anywhere a download link to the latest version of the drum and synthstepp:r.
    (is there somewhere an 'official' downloadlink to the drum and synthsteppr?

    The good thing is, the control surfaces appeared back in the dropdown list. So that's ok.
    But of course that was not the initial problem, which unfortunately is bigger and still persists. 
    (on both computers, pc desktop and macbook pro)

    The moment I select the livid cntrlr as a control surface, the ADSR settings and such dissapear, same with the synthsteppr.
    extra info: because of that I also can not select the mod (1,2,3,4#), and the 2x16 step sequencer is nowhere to find, if I press every button on the controller, I can not find the page to add the steps.

    There must be something that doesn't communicate well between the control surface script and the drumsteppr.


    Thanks for any help. My deadline is coming closer, so hopefully the problem is fixed soon.

  • edited September 2018

    Sounds like you have some conflicting files.  Unfortunately, there is no installer for this stuff at the moment, so you'll have to manually check for duplicate files and remove any that are extra.  My guess is that you probably have multiple versions of modtranslator.js,  and an older one is getting loaded instead of the correct current one.  Make sure that you've removed all the old files and then try installing again.  If the scripts are working (sounds like they are), the only stuff that needs to be replaced is what lives in the Max 8 Packages folder.

    One thing I should mention:  there are no mod numbers in the Livid CNTRL v2 script.  That functionality was replaced, so that whatever device is selected in the GUI is the current mod Device.  You enter mod mode by toggling the top, 3rd from left encoder button.  I'm just reiterating this fact in case you were expecting the same behavior as the original CNTRLR script.  There is a CNTRLR retro script included with the new distribution that is very similar to the original script, but it is necessary to name your mods with a specific prefix in order for it to find them correctly.  Let me know if you have questions, I can try and explain.


  • Hi Amounra,

    Thank you for the information.
    I'll try to delete everything I can find concerning the old or duplicate files as you say.
    Hopefully your guess is a good one.

    The moment I know more, I'll post it here.
    Thanks again!

  • there a download link to the latest or most compatible version of the drum and synthsteppr somewhere?

    Because I want to delete them and reinstall. 

  • edited September 2018
    Ok, I think...(fingers crossed) it is solved.

    At last I managed to load a drumrack, and the ADSR settings are staying active + the stepsequencer on the controller lights up.

    I didn't had double modtranslator.js file.
    But I think I know what the problem was. (correct me if I'm wrong here)
    I discovered -by accident- that the synthsteppr, and drumsteppr MAX devices, are sitting in the m4m8 folder, in the subfolder 'Patchers/mod_b999'. 
    While I was launching allready installed synth and drumsteppr from another installer, which obviously didn't work together.

    So maybe it's good to also mention in the readme file that the maxdevices are actually present in the (Mod_b999) folder, thus the only thing needed for it to work is installing these devices from the patches folder in the folder the user wants, or loading the mod_b999 folder in the Ableton browser.

    Also not everybody knows I guess that 'patchers' might be the same as Maxdevices or so... If the folder was named Maxdevices, I think I would have looked in to that way earlier and prevented my frustration.

    Wow, am I glad that this frustration is gone...pfff...(I hope :-) ) 

    Thanks for the help a.

  • edited September 2018

    Untill now, it seems to be working more or less....

    But I have yet a few questions concerning the drumstepper (I'm learning :-) )
    In the video tutorial on vimeo, the guy loads a drumrack, fills it with samples, and ALL the rotary knobs are assigned to different parameters from the drum rack.

    Setup in tutorial is this:
    - top row: sound param
    - 2nd row: sound param
    - 3th row: sequence param.
    Which is very handy, as it visually mirrors the drumsteppr instantly.

    My setup is this:
    - top row: general param (select device etc)
    - 2nd row: sound param
    - 3th row: sound param
    - 4th (invisible) row: sequence param.

    I noticed a post, where the answer was: use the shift button, second one...or something like that to reach the bottom row.
    But I can't find clear info on what is that second button to press...what/where is the shift, that makes me able to use the bottom row? (I pressed about every button, but can't figure it out.)
    + I would prefer not having to use a shift button, just like in the tutorial.

    An extra issue: the bottom right rotray knob, if turned, the light of the knob above this one seems linked. So the lights of both knobs do the same thing... is this something that has to be fixed in the editor?

    Sorry for all my questions, but I'm almost there. :-)
  • edited September 2018

    I tought the ring leds of both rotary knobs had the same midi value, but in the editor, they have different values so its really weird that one rotary knob addresses both ring leds.

    Also the other way around: the other rotary knob also addresses those 2 ring leds.
    So the bottom right and the one above, if adjusted either one of them, both ring leds move.

    If i send midi from the editor (in order to inspect the leds), then also the two ledrings respond, alltough its a different midinote #,
    (110 and 111) ...other rotaries respond like it should.
    Id numbers are 7 & 11
  • Regarding your last post (multiple encoders mapped to the same parameter), I can't reproduce this using the current version of Live.  Everything works as expected for me.  Have you done a factory reset via the editor for your controller?

    The "shift" button that allows access to the parameters 9-12 is the top, second from left encoder button.

  • Of course I did a factory reset. I mean, I do actively troubleshoot like it should.

    But you know...I'm tired of Livid. It's a dissapointment from beginning until end.
    Hardware is poorly built, quality of components is very poor.
    Software is unreliable as fuck. Doesn't work on my mac.
    The rotary encoders don't work like they should.
    Nothing is plug and play...
    Way too expensive.
    Poor to no support at all.
    I've had nothing but frustration with this expensive brand. I really wish I had never bought the CNTRL:R.
    Looked promising at first, but it's terrible.

    Ok, you ansewered some questions Amounra, and thank you for that, but you are the only support that here on the forum, and for a brand that sold worldwide, that is not enough.
    All the Livid (CNTRL:R) custormers paid lots of money and that disserves a service after sales....just like any other brand does.

    I paid 450euro for a second hand CNTRL:R and had nothing but trouble, with the software and the hardware.
    That money would have been so much better spent on any akai controller + beatstep pro...stuff that actually works.

    Its a really is.

    It is frustration right from the heart. Sorry.

Sign In or Register to comment.