Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Twitter

CNTRL:R White - Steppr Colours Problem

edited January 2018 in Hardware

Hello all,

I recently obtained a CNTRL:R White.
I am under ableton 9.7 and Max 7.3.2 and I installed all the Remote Scripts for the CNTRL:R which are working and are recognized by Ableton (took me 3 hours to find the correct version but all fine :D)

I started using the Steppr to create my drum patterns, I followed the guide and I made it work.
Nevertheless, I experience few problems, for example, when I play a sequence, the 4x4 pad does not lit accordingly to what is played.
Only the current sound that I am manipulating is lit.

Furthermore, when I make a sequence, the buttons of the two bottom rows are always lit and I do not see the step timer pass (only when I have the 16 buttons pressed and sequenced, the colour changes (blue for the 1st, 5th, 9th 13th step and dimmed white for the rest)

When I want to mute an instrument in the drum rack, the button remains lit. I had seen in videos for CNTRL:R black that it was the opposite, the button is in normal state off and it lits when you mute an instrument in your drum rack and that you also have the steppr moving in the far bottom button row.

Is it a firmwire thing ? Or just with the new Remote Scripts that this is not possible? Is it the Max Version that should change?

Anyone had this thing with CNTRL:R White edition? I tried to change the colours from the file but I cannot manage it for the Steppr, I cannot find the right line for it.

Any info on that?

Thanks in advance


  • Hi Filoxenos,

    Please double check that you have the correct version for your controller.
    For newer versions of Ableton Live the scripts should be installed manually.

    Current downloads support v9.7.5 and newer.

    Older downloads are available at the bottom of that page.
    9.6.2 and higher require manual installation as described in the links above, whereas before then, we have installer packages.

    If that does not resolve the problem,
    it may be a configuration issue (either device firmware or Ableton Live configuration).
    You may try running a 'Factory Reset' (labeled as 'Default Settings' in the Online Editor documentation) in the Online Editor to make sure that you have the standard Cntrl:R settings.

    You might also try a fresh Ableton Live Set, and see if the problems persist there.
    Previously mapped MIDI Messages done by the 'MIDI Learn' feature of Ableton could be interfering with the operation of the script.

    If you continue to have these problems,
    can you post a screenshot of your Ableton Live's MIDI Settings Window?

  • Hello Moon,

    Thanks for getting back to me.
    I managed to manually install the Remote Scripts, with the installer it did not work.

    I will double check the version that I have that at 90% it should be fine.
    I will try doing a Factory Reset and I will get back to you, and I will post a screenshot when I get home.

    Thanks in advance :)

  • edited January 2018

    Hello Moon,

    So, the colour thing & the sequencer thing has been repaired after I tried Default Settings in the Online Editor. 
    The machine seems to work more smoothly.
    Nevertheless, some things are still not working as intended (I started a new Ableton Template with no MIDI mappings - Cntlr:r was the only device connected to Ableton when I tried it again):

    1) When I have DrumSteppr and Synthsteppr in the same Ableton Live Set, CNTRL:R stays on and controls only the second Steppr that I introduced to the set. Is this normal? (of course each Steppr is in a different track and introduced as it should be, first the steppr then the instrument blabla.)

    2) The knobs on the upper-right part that are supposed to treat the EQ Three, control indeed the EQ Three when it is the only device in a track. When I introduce an instrument or a Steppr, the knobs control 3 random parameters of the instrument. Is this normal?

    Thanks in advance.
  • 1) The CNTRLR will follow whatever you have selected in Live.  It should assign the controls automatically when you select the device in Live's GUI (it will show a little hand next to it).

    2) If I remember correctly, the EQ functionality only works when the EQ device is the first one in the track.  I'll have a look at this when I get a chance and try to get back to you.....

  • edited January 2018

    Hello Amounra,

    Thanks for getting back to me.

    1) Let's say I have DrumSteppr in Track 1, then in Track 4 I put SynthSteppr. When I am in Track 4, it controls SynthSteppr. When I use the knobs to get back to the Track 1 and control the Device DrumSteppr, CNTRL:R with the knob M4L enabled, it still controls Synthsteppr of Track 4. I cannot control DrumSteppr anymore of the track 1 even if it selected. It is "stuck" on Synthsteppr of Track 4

    2) EQ cannot be in the first place when I put an Ableton Instrument.

    Bonus extra point :
    3) In DrumSteppr Mode - I do not see the pad lighting as my pattern is played, as we see it happens in this video in 56:26


    Any info on that?

  • I'll have a look tomorrow when I'm at home and have my CNTRLR for testing.  Honestly, it's been some time since I looked at this, so its possible something has gotten broken, but everything worked the last time I looked.

    One thing I can tell you, though, is that I won't be able to help with older versions of Live/Max.....I only keep current builds around and its very time consuming to try to backdate my installation for support purposes.  So first thing I'd do if I were you is update to Live 9.75 and Max 7.34, then update the m4m7 package from my GitHub repository and replace the Python scripts in your Live app bundle.  You might find some problems you're finding clear up with the current build, if you're not running it now.

    If you need any help with updating, I'm glad to oblige...


  • Aight, Ill try updating and I will let you know my brother, thanks for the information, you are a true knight of the CNTRL:R legacy.

  • edited January 2018

  • edited January 2018

    UPDATE: I just updated everything as you said, I downloaded all the new Scripts, I connected CNLTR:R with 9.7.5 Live 64 bit and Max 7.3.4 and unfortunately the same problem persists. It's as if I can only have one "xSteppr" per live set, otherwise the cntrlr bugs and cannot seperate and distinguish the two "stepprs" in the Live Set. I have DrumSteppr 1.5 and SynthSteppr 1.4, dunno if they are the most recent ones.

  • Not sure of version number, but the most current ones are the ones from the m4m7 repo, they should be in ~/Documents/Max 7/m4m7/patchers/Mod b997/.   Make sure you've followed the instructions in the m4m7 readme about where to put the package so Max knows where to find the files.  Let me know how it goes ;)


  • edited January 2018

    I just checked the versions in repository, and although I'm using the AumPush script (I don't have a CNTRLR to check with right now), both the SynthSteppr and DrumSteppr are working as they're supposed to, they switch between instances without a problem.  I can't imagine a situation where the CNTRLR would behave differently (as the mod portions of the Python scripts are fairly identical and use the same core), but I will double check later when I'm home with CNTRLR just to be sure for you.

    One thing that could conceivably be an issue for you:  there is a 'lock' button on the CNTRLR that will prevent switching mods when it is activated, but I don't think this the problem you're describing.  Just in case, you could try toggling the modLock button, which is accessed by going into deviceSelectorMode (top left encoder button) and pressing the bottom right 4x4 grid button.  Again, though, I doubt that's what's going on.....I suspect this is just a case of using out of date files.

    FWIW I'm working on packaging up this stuff in a new Max Package for the impending release of Live 10 (just so everything is in one place and its easier to understand what to do to get things working), but honestly the Stepprs were a collaboration, and very messy, and VERY hard to edit at this point so there won't be any changes beyond any small incidental fixes for Max8 when it's released.  You might want to check out "Hex" (also in m4m7 repository), as it performs the functions of both stepprs plus a lot, lot more, and I will continue development for it through the foreseeable future.  

    Docs are somewhat out of date, but all the essential info is here:


    edit::  haha, I guess we already corresponded about this some time ago (via Stephan Bodzin).....cheers :)

  • I can confirm your reports.  I'm getting the same problem here.  I'll get back to you when I have a solution.....really scratching my head here though.


  • Should be fixed now, I've pushed a new build to GitHub.  Just download the package and replace your current one in the Max directory, there's no need to do anything with Python files.  Thanks for bringing this to my attention, somehow I totally missed this problem the last time these files got updated.  And, of course, let me know if you find more problems, as it could be an easy fix like this one was!


  • Man you are a god :D 

    It is fixed yeap! 
    What about the EQ thing? 
    Got any insight on this? 
  • EQ assignment to the right knobs is dependent upon setting a flag in to true, line 25:

    EQS_INSTEAD_OF_MACROS = True  #Maps right dials to EQs when "True"

    If you don't make this change, the script will use the default behaviour, which is to assign the knobs to the first three macro controls of the first rack in the track.

    This is working for me, it selects the last eq device in each track, and assigns three knobs (vertically) to the first three gains of each eq on the four tracks available in the session ring selection.


  • Amounra,

    Thanks a lot for your time mate.
    This has been fixed as well, I am grateful for your help.

  • edited January 2018


    Is it possible to control the variables in red (which would be in position 9-16) with the CNTRL:R ? (check picture)
    I mean, as if I can control more than 8 variables when press the I second knob in the upper 4x3 middle row in the Stepprs.

  • Unfortunately, no....that would require a pretty extensive rewrite of both the devices and the Python scripts for CNTRLR. 

    It is something I could do pretty easily with the newer framework in Hex....just fyi.


  • edited February 2018

    Hey amounra, it's me again.
    I have couple of questions about Stepprs mostly.

    A) How can I change the scales directly from the CNTRL:R without clicking in the computer?
    B) Concerning the Scales, is it possible to change the scales or am I obliged to only have 6 "ways" (I , II , III, IV, V, VI) TO be honest, I am quite lost when I am playing live with the scales, I am at C minor for example, but none of those scales correspond exactly to all Cminor notes. Do I have to change the scale of CNTRL:R before going to Max4Live mode?

    A) How can I chose the "select, add, edit" via the CNTRL:R directly?

    Thanks for getting back to me :)

  • Just noticed this post, sorry....

    Won't have my CNTRLR in front of me until tomorrow, but off the top of my head:

    B)  VI should be Minor, its possible that somehow the files regressed to an older version where the note values for that mode were incorrect....I'll have a looksee and get back to you...


  • edited February 2018

    Still pondering this....I had to rebuild all the Live scripts for Live10 release over the weekend, that took precedence (sorry).  I'll try to get back to you on these questions ASAP.


    edit::  My Live9 authorization got scrubbed when I installed Live10, so I can't actually look at this until Ableton gets its sorted for me.  I'll be in touch when I'm able to look at it again.

  • edited March 2018

    Again, sorry for the delay in getting back to this.

    A) How can I change the scales directly from the CNTRL:R without clicking in the computer?

    You can't, unfortunately.  This is possibly something that could be fairly easily added to the left-bottom encoder.

    B) Concerning the Scales, is it possible to change the scales or am I obliged to only have 6 "ways" (I , II , III, IV, V, VI) TO be honest, I am quite lost when I am playing live with the scales, I am at C minor for example, but none of those scales correspond exactly to all Cminor notes. Do I have to change the scale of CNTRL:R before going to Max4Live mode?

    The scales should correspond to the standard scale modes, if you want to change them you'd have to manually edit the file "assemble_seq_parent.js" in the Max directory (Max 7/Packages/m4m7/javascript/steppr/assemble_seq_parent.js):

    modes[0] = [0, 2, 4, 5, 7, 9, 11, 12, 14, 16, 17, 19, 21, 23, 24, 26, 28]; 
    modes[1] = [0, 2, 3, 5, 7, 9, 10, 12, 14, 15, 17, 19, 21, 22, 24, 26, 27];
    modes[2] = [0, 1, 3, 5, 7, 8, 10, 12, 13, 15, 17, 19, 20, 22, 24, 25, 27]; 
    modes[3] = [0, 2, 4, 6, 7, 9, 11, 12, 14, 16, 18, 19, 21, 23, 24, 26, 28]; 
    modes[4] = [0, 2, 4, 5, 7, 9, 10, 12, 14, 16, 17, 19, 21, 22, 24, 26, 28]; 
    modes[5] = [0, 2, 3, 5, 7, 8, 10, 12, 14, 15, 17, 19, 20, 22, 24, 26, 28]; 
    modes[6] = [0, 1, 3, 5, 6, 8, 10, 12, 13, 15, 17, 18, 20, 22, 24, 25, 27];

    The numbers are the scale steps, you could potentially change them to whatever you want as long as the length of each array remains the same.

    A) How can I chose the "select, add, edit" via the CNTRL:R directly?

    Press the second from right, second from top encoder button  (button 2,2).

    Hope this helps :)


  • edited March 2018

    Hey Amounra, thanks for getting back to me!! OK cool, these info are amazing, I'll try to see what I can do with the file directly in regard to scales. 

    I am experiencing another problem at this moment (and I cannot explain why)
    The SynthSteppr stopped working in my Live Set Template that I am preparing (attached photo)
    When I start a new project and insert a new SynthSteppr, it works.
    When I insert a new Synthsteppr in my existing Live Set template, it still does not work.

    What can I do to make SynthSteppr start rolling again?
    As you can see in the photo everything is rolling, except for the SynthSteppr which is as if it was out of order.

    THis is the error log from Synthsteppr if it helps

    Update: When I insert a new SynthSteppr, it gets the message for my Livid Cntlr:r
    The old Synthstepprs in the Live Set do not get any message (add notes, change pattern) from the Cntlr:r
    And of course the Synthsteppr is not rolling. 

    Update 2: DrumSteppr is rolling but it does not get any message for the Cntl:r:, Cannot mute or change anything
    Update 3: I saved all Stepprs of my set then I deleted them from my set and I introduced them again where they were. DrumSteppr came back to life and I can control it from the Cntrl:r but SynthSteppr is still dead, although I can change patterns, add notes but it does not roll.
    Update 4: I deleted all Stepprs again and then I introduced the default Steppr. At first it did not roll either. Then I do not why, I stopped and I pressed play and the default Steppr started working in my Live Set. Then I replaced the default stepprs with the Stepprs I have saved and now they are working again ... Any clue? I would not like to experience this in a live performance :D 

  • edited March 2018

  • edited March 2018

  • edited March 2018

  • edited March 2018

    For some reason the last screen shot didn't come through....

    BUT, what would be most helpful to me is to see a screenshot of your Max window when this is happening....chances are it may show some errors, which may help me sort out what's going on here.

    You can see the Max console by right-clicking (or ctrl clicking) the steppr device's title bar and choosing the "Open Max Window" option.

    Also, can you tell me what versions of Live & Max you have installed?


  • There we go with the Error windows

    I have 9.7.5 Ableton & and I am running 7.3.4 Max
  • Sorry haven't been online much lately.  You should drop me some email, I think this will take a little bit of back and forth and I'm not always so good about checking here (plus its hard to send attachments via the forum)....

    I'll send you my email via PM if you don't already have it.


Sign In or Register to comment.