Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Twitter

Base Remote Script Errors in Live 9.2

My Base (v1) has gone insane when using it with Live 9.2. It works fine for a minute, then will not switch modes, then starts doing things that make no sense at all. Once leaving launch mode, there is no going back. As for send and device modes, a different thing happens each time I press the 2 or 3 buttons. Usually nothing happens the first time I push the button. The second time, it will usually switch the screen to "S" or "D", but the pads do not illuminate. Various colors of lights appear in the select track buttons at top the third time. Some controls, like track select, seem to continue to work. But the pads and eventually touch faders cease working.

I am using Live 9.2 on OS X Yosemite, 2012 Macbook Pro. My firmware is up to date, things appear to be normal when using the online editor, and I've downloaded and re-installed the most current Live Scripts package.

I have viewed the Live 9.2 log.txt file and there are thousand of lines with remote script errors. I won't paste the whole thing here, but here is a small sample of what I'm seeing:

185012 ms. RemoteScriptError:   File "/Users/versonator/Jenkins/live/output/mac_32_static/Release/midi-remote-scripts/_Framework/", line 214, in grab

185012 ms. RemoteScriptError:   File "/Users/versonator/Jenkins/live/output/mac_32_static/Release/midi-remote-scripts/_Framework/", line 224, in _on_received_set

185012 ms. RemoteScriptError:   File "/Users/versonator/Jenkins/live/output/mac_32_static/Release/midi-remote-scripts/_Framework/", line 603, in _do_enter_mode

185012 ms. RemoteScriptError:   File "/Users/versonator/Jenkins/live/output/mac_32_static/Release/midi-remote-scripts/_Framework/", line 206, in enter_mode

185012 ms. RemoteScriptError:   File "/Users/versonator/Jenkins/live/output/mac_32_static/Release/midi-remote-scripts/_Framework/", line 174, in enter_mode

185012 ms. RemoteScriptError:   File "/Users/versonator/Jenkins/live/output/mac_32_static/Release/midi-remote-scripts/_Framework/", line 160, in _set_layer

Help me Amounra Kenobi. You're my only hope.



  • I think I've got a handle on this problem, as soon as I have a chance to get all the scripts tested and pushed to repository, I'll post a link and some instructions on how to fix the problem.  Thanks for the report, and sorry about the oversight.

  • I got the same behavor (more or less) .. I upgraded to ableton live 9.2 one week ago.. and I received my base 2 few hours ago :-(
    I am a bit frustated ;-)

    Good luck to upgrade the scripts :-) I am looking forward to getting the new scripts :-)
    meanwhile do you have any idea to overcome the issue, a workaround ?

    PS: where can you get the Ableton live log file on MAC ?

  • This will explain where to find the log.txt file:

    And have no fear, the force is strong with amounra.

  • thx :-)

  • Don't worry guys, I hope to have this resolved sometime today.  I know where the problem is, I'm just trying to get all my ducks in a row to make sure I get everything fixed in all the scripts before I post them.  Sorry about the trouble and thanks for your patience :)


  • Ok.  So, as far as I can tell, the version in our repository has been correct all along (and is not causing these errors).  I think that the installers we have published are out of sync with the current state of our repository.

    Unfortunately I can't make new installers, and Peter (who does that sort of thing) is away for a bit.  However, the versions in our repository should work fine, you'll just have to install them manually.

    If you download a zip of these files (there's an option to do so on the lower right hand side of the page) and place the contents into your MIDI Remote Scripts folder (however, please exclude the and license files), then things should work fine.

    If someone that's having problems can please do this and confirm that this is a fix for your current predicament I'd be indebted.  I need to confirm that there isn't another issue that I'm not seeing here before I can commit to making a new installer out of this version.  Thanks in advance!

    If anyone needs more direction about how to install this manually just let me know, I'm glad to help.


  • Hello,
    I downloaded the whole as you described on my MAC :-)
    I restarted Ableton Live 9.2 .. and started to play with my BASE II ...
    it's working fine now !!!!

    Big Big Big Big thx :-)

  • Awesome, thanks for the heads up :)


  • Thank you for your help with this. I'm hundreds of miles away from my Base for the next week but will be sure to try your suggestions once I'm home and report back.

  • I was having the same trouble but copying over all the Livid_Base folders and the _Mono_Framework folder from the Github repository to the MIDI Remote Scripts folder fixed it for me. FYI, without copying over the new _Mono_Framework folder I wasn't seeing Livid Base as a control surface in Ableton.

  • Awesome, thanks for the replies guys.  We'll have new installers as soon as Peter is back from vacation, in the meantime let me know if you run into anything else!


  • Is there an ETA for the new installer to be available? Thanks.

  • Should be sometime this week....sorry for the delay, the "installer guy" has been on vacation.


  • Does this scripting fix work for Live 8.x??
    I just bought a Base II and installed the Remote Script and now have some issues:
    Now, when I switch between Launch and any other mode, and return to Launch Mode, the Touch Fader LEDs become non-responsive. Only the LEDs, not the actual Fader within Live, but having a visual fader position indicator is important for how I operate in performance.
    Will installing this .zip file correct this issue?

    Mac, Live 8.4.2 32 bit, Base II

    If there's another solution to this, I would greatly appreciate direction to that info.


  • Disregard my previous post. I was creating my own problem:
    I found that some MIDI mapping I tried to add was apparently interfering with the functionality of the script that provides the LED follow on the touch faders.
    I was trying to over-ride the touch slider track volume control by assigning them through MIDI Learn to a macro for a DJ-style bandpass volume fader run by an effects rack (much like Will Marsahalls "Smart Fader"). The MIDI Learn mapping was preventing the standard LED follow of the volume faders from working.
    If anyone has clues on how to overcome/overwrite/bypass that part (and potentially others!!) of the remote script so that the touch faders in Launch/Send/Device modes can be mapped to Macros or other parameters, I would love to hear about it.

    What I'm trying to do is this:

    I would like to use some of the Remote Script functionality:
    - the light-up pads/grid that lights up when a clip is added and changes color when played. Def a must-have.
    - LED follow on the touch faders for levels - This is important for me to see when performing.
    - User modes.

    What I'd like to add/modify:
    - LED follow on the touch faders, but not just for track volume. Ideally these faders would light up when they're assigned to any parameter. Assigning them to control a macro that runs an effect rack is one example.
    - Is there a way to have the clip grid/launch lights show in user modes?

    Thanks for the help, everyone.
    Also, pardon me if I'm writing this in the wrong place/ hijacking this thread. I'm running Live 8.4.4, so this post might be better on it's own elsewhere. If so, i beg forgiveness and ask the mods to move as they feel is best. OK, on to the next...

Sign In or Register to comment.