Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Twitter

CNTRL:R Editor disables Local Control (bugged)

edited January 2014 in Hardware

Just received the CNTRL:R and am of course delighted.

My coffee here is excellent, just the CNTRL:R Editor makes me livid as it seems to bug the controller for some odd reason.
Initially, the LED rings gave local feedback, once having opened the editor there is no local control anymore, even with LC activated for the encoders, data saved and sent to the controller, same goes for the buttons, no lc possible. Sending MIDI from applications does not bring forth any change in LED display either. Somehow I got it fixed an hour ago and all LEDs reacted perfectly. Then I ventured the editor again and voila: all LEDs were set to zero velocity with no means of changing this. The editor is, however, able to send "All Notes On" and the encoder-sequence, but local control as such does not work.
I have reset the CNTRL:R, rebooted, sent all kinds of MIDI data and what not, the input port is Cntrl_r Controls, the encoders send values but can't receive them. 

I have tried the online editor once again with jazz & java all being up-to-date but it doesn't connect to the device at all.

I would really relish some insight on this and of course would love to learn about a technique to tackle it permanently.

thanks v much in advance for help!


  • If you're using the Ableton script, it turns local control off.  That could be your problem....

  • hi to moon & amounra & thanks for the replies.

    OS :: OSX 10.7.5
    Browser :: Safari 5.1.7
    FW :: CNTL_R 0 1 1 1

    I am not so much concerned about the online editor because it hasn't worked at any time before and I did already post a thread about this issue. In the end the CNTRL:R Editor should do the job…

    concerning the Ableton script: I haven't installed the remote script for Live 9 yet as for I am working on my own. I only tried to launch the Monomodular script for Live 8, but that was !after! the issue first occured as far as I can remember — to actually check whether the LEDs work or not. I dove into Hex and the LEDs did not respond in it. So even if the remote script deactivates local control, the encoder rings should receive and display midi data in a functioning Monomodular.

    I have rebooted both the controller and my Mac and the LEDs where back to local control. Having launched the Editor once more (just now after I read your replies), the LEDs are instantly frozen and back to useless.

    What's more, I have the following error messages printed in the Max window on start-up (refer to pic):

    In the editor, local control for the encoders is by default ON, yet they're frozen.
    turning local control for buttons ON does not work either.

    let's hope this helps,
    thanks guys.
  • perhaps unfortunately, I changed the channel settings for the 4 banks and then saved the current settings to the controller, seemingly with the flawed local control — so now rebooting or factory resetting doesn't work either, stuck with the ill now.

    there seems to be some javascript hindrance, after having reset the controller, twisting an encoder or pressing a button gives these continuous messages in the Max window:

    the editor doesn't follow the midi commands any more either (highlighting chosen buttons etc.)

    I am a kinda lost…
  • FWIW, make sure you don't have any other MIDI apps going on in the background, this often will hijack the connection.


  • Hi there. I just got my cntrl:r in the mail this week. Very excited to start messing around with it. I am having the same problem with the desktop editor causing my LED rings to stop responding. I am seeing the exact same error messages as shogun posted in the first photo:

    I am using OSX 10.9.2, FW 0 1 1 1

    The web editor works fine and does not cause this problem, so I'm using it for now. Just wanted to let you guys know that I'm having the same issue.
Sign In or Register to comment.