Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Twitter
  • individual bank button

    That is a tutorial video for the CNTRL:R Ableton Live Script. Are you using Ableton?
    Here is an answer from another thread:
    Individual bank buttons are coming in a firmware (and software) update in the next month or so.  This feature is currently available on the Base, and is currently being ported to the Code and Cntrl:R. 
    The individual bank buttons you have seen on the controller, are software based and part of the Cntrl:R Ableton Live Remote Script, and are referred to as 'Mod Slots' (aka. Mods) in the documentation.
    http://wiki.lividinstruments.com/wiki/CNTRLR_Ableton_Live_Remote_Script#2._Mods

  • Code 2: initialisation strategy

    Hello there,


    So I am plugging the code2 at the back of the DSI tetra, which has 400 parameters for one patch.
    The idea is that when a new patch is loaded, the code2 will receive these 400 parameters (more or less).
    For this, I will have to make use of the 4 banks.

    Question:
    I want to loop through the banks using program change and for each send for each a bunch of sysex:


    plus other will be one off sort of stuff

    So does this think reasonable enough?

    Cheers
  • CustomProject//KeyboardController

    Hey Livid Instruments,

    Currently im android developer / technology enthusiast and working on a Open Source USB/MIDI Keyboard Control. 

    Two of you products interested me "The BASE" & "The CNTRL:R". So i have few questions below :P 


    1. Can the base or cntrl:r be replicated with the diy builder ?

    2. Do you make custom pcd and what would be the cost ?

    3. Those the diy builder have a editor ?


    Thanks, 

    M-Kay | Mark N

  • Brain Jr.: Any way to change MIDI channel on the fly?

    Hello Moon.  Thanks for the response.  The sysex message doesn't really help me, but it's good to know that each control can send on its own MIDI channel.  In that case, there are two ways to achieve (easy) user control of the MIDI channel: (1) assigning some control to change the 'global' MIDI channel, which would require individual controls to have some type of 'follow global' option for their MIDI channel assignment (otherwise they would use their assigned MIDI channel), or (2) using some control to select presets, which would swap in a different set of controller assignments for all controls when a different preset is selected.  #2 affects the editor much more (and memory on the microcontroller), so #1 is probably the easier solution to implement.  Presets are more flexible, however.  It would be nice to be able to map buttons to presets, so pushing a button recalls a preset (and the LED associated with the button lights up).  I doubt anyone would need more than 4 presets...


    But it would be a significant firmware change either way, and maybe there aren't enough people interested in this functionality to make it worth the effort.  A Novation Launch Control has 16 pots, 8 buttons, and 8 user presets and costs $80.  Probably the best option for me at this time...  
  • seamless integration of Alias 8 ?

    hi Peter,

    I am using Safari, I've tried it once more yet the problem persist. Having said that, the actual names of the ports (i.e. 'Code' or 'Ohm') don't appear, so I don't know which '(Controls)' I am selecting.

    Opening the index.html file for the offline version ended up loading a blank screen for ages and I had to retype my very message here after Safari got stuck somewhere…

    regarding #2 — thought so! I had, however, chosen a different controller of yours by now anyway… ;)

    the changing of banks via program change messages was entirely new to me — but mega revealing! Playing an Ableton set now allows me to switch to the banks of my controller directly without having to cycle through! I know this info is part of the device's wiki's but I've come across users who would actually love to know about this feature! It works beautifully for the Code when setting up clips in Ableton:
    • MIDI output —> Code (Controls)
    • MIDI Ch. —> 16
    • Bank Ø, Sub Ø, Pgm —> 1/2/3/4 in individual clips

    assigning these clips' play buttons to buttons on the Ohm allows me to switch to the Code's Bank 3 directly, 4, 1, 2 and back to 4 if needed. Now that's brill!

    However, to achieve the same on the OhmRGB one must send the program change messages on Channel 1 as opposed to 16 I was to find out.

    Thank you guys…
  • seamless integration of Alias 8 ?

    Regarding the editor - what browser are you using? Strange that it is stuck in "fetch settings" mode. 

    Regarding #1 -  If you want to run it locally, it's easy. Just open the folder, find "index.html" and double click: http://wiki.lividinstruments.com/wiki/Online_Editor#Offline_Version
    I need to get rid of the "How This Works" document in that package - apologies for the confusion.
    Regarding #2, I think Jay misunderstood - it is not possible to have different settings in each bank. Each bank is differentiated only by channel. All banks have the same CC/note and toggle/momentary settings. However, the Alias8 always listens for changes to LED states on all banks, so the LEDs can be updated, even if the current bank is not loaded.
    Regarding changing banks programatically: you can use program change messages, sent on the settings channel (by default, channel 16). Program Change values 0-14 will change the active bank.
  • seamless integration of Alias 8 ?

    Regarding the editor - what browser are you using? Strange that it is stuck in "fetch settings" mode. 

    Regarding #1 -  If you want to run it locally, it's easy. Just open the folder, find "index.html" and double click: http://wiki.lividinstruments.com/wiki/Online_Editor#Offline_Version
    I need to get rid of the "How This Works" document in that package - apologies for the confusion.
    Regarding #2, I think Jay misunderstood - it is not possible to have different settings in each bank. Each bank is differentiated only by channel. All banks have the same CC/note and toggle/momentary settings. However, the Alias8 always listens for changes to LED states on all banks, so the LEDs can be updated, even if the current bank is not loaded.
    Regarding changing banks programatically: you can use program change messages, sent on the settings channel (by default, channel 16). Program Change values 0-14 will change the active bank.
  • seamless integration of Alias 8 ?
    1. Yes editing the settings on the alias is super simple. You can use the online editor and download it as a zip if you want to use it offline http://wiki.lividinstruments.com/wiki/Online_Editor#source_.28offline.29

    2a They can be different on each bank. The only global setting is the Channel per bank.

    2b. Yes toggles can be set per button and bank http://wiki.lividinstruments.com/wiki/Online_Editor#Button_Inspector

    3. Not sure if Reason support sysex, I imagine it does, but you can do this with sysex http://wiki.lividinstruments.com/wiki/Alias8#26_:_Change_Current_Bank

  • Base "Shift" Button

    Hi 


    I'm looking to make a manual/user setup with Ableton 9 and Base.
    What I want to do it's to have chains of fx to control and since i don't have enough sliders, i want to use the upper buttons as kind of "shift" button, that will allow me to use same sliders for different devices.
    for example if upper button #1 is enabled it will control/send midi from sliders a1, a2, .., a8
    if upper button #2 is enabled it will send from sliders b1, b2, .. b2
    and etc.

    is it possible?

    Thanks!
  • Livid Code 2 - no led response

    oh and another thing (sorry!!) :::

    when opening a project in Ableton the assignments of macros in the 'encoders'-Mod don't have the parameters affixed to them (green LED) so I have to affix all breakpoint-envelopes manually on start-up every time before I can set off with the sound morphing.… any clue as to why this may be? this doesn't get saved when I save the project. The only angle I ahve on it, is that perhaps parameters which are assigned to more than one macro a not affixed to it on start-up. Hence q#2: How can I remove parameters assignments from macros int he encoders-Mod?? is this at all possible?? sorry, but this would be important to know!
    Keep up the good work!
  • Reason 6.5 & Base
    hi,

    using Reason 6.5 ( build 2615)

    with BaseReasonMaps_Alpha01 and after some time(  few min )  i get a error :
     
     Livid, Base. MIDI output: LUA Error: [string "Base.lua"]:409: bad argument #2 to 'format' (number expected, got string)

    when do You planing to update Reason Base script ?

    thanx

    emil




  • Ohm 64 - switch off lights?

    Hello there!


     Recently I wanted to switch back some of the lights on my Ohm 64 on to use with Cell DNA. After changing them round in Ohm Editor they started acting a bit weird - like all the middle 64 clip buttons wouldn't like up (all apart from almost the bottom two rows). 

     So anyhow after a bit of fiddling around I decided to just do a factory reset and all the lights stayed on when I fired up Cell DNA. So far so good.

     But now the word thing is when I trigger a clip (like #1) the clip next to it (#2) is triggered and that button light goes out. Happens with all the clip triggers - even #64 triggers #1.* 

     Whassup with that? Any ideas for a fix please?

     Muchas gracias! 

     * (All the others knobs/sliders/buttons appear to trigger the correctly assigned things.)
  • Big Project for Big Beginner !

    Hi !


    firstly I'am sory for my English more than basic , I hope you understand me ..

    I just discovered this forum, after reading several articles, I have a question:
    - Is it possible to build a controller with 200 buttons, 40 potentiometers and 200 LEDs?
    I saw that the BrainV2 can handle 128 buttons ..  can i join two BrainV2 to reach my goal?

    best regards, 

    Jcuba
  • Base editor and Windows 8.1

    Hi All


    I am currently using Windows 8.1 (not by choice!) and feel that the online editor does not work well in it.  It could, of course, be user error, however switching to a PC with windows 7 seemed to fix all issues.  Was wondering if anyone else has experienced this?

    Now to the fun part, trying to explain whats going on.  Let me first describe what I am trying to setup. I am trying to make seven banks all the same apart from Midi channel, kept at default settings. Each page has a unique color on all pads/buttons/faders 7 of the 8 momentary buttons select the banks, the right side LED color corresponding to the bank's color. MIDI assignment is as follows: Drum Pads (Note 1-32)  Faders (CC 1-8) Buttons (CC 9-16) Master Fader (CC 17).
    I have all LED local control disabled to start, select bottom left drum pad, assign it to note#1, note output is checked, all others unchecked, mode=ccs.
    I then hit group to assign the other 31 pads in sequence.For LED, selected bottom left pad, assigned color, assigned Note#1 and hit group. At this point i have all the pads doing exactly what I want so I save to device.
    Faders - Select Fader 1, CC#1, all options unchecked, LED style=Walk, Color=(Bank Color).. Changing the color has no effect with local control on or off. Apart from that all seems to work correct.
    Buttons - Select button#1, assign Note/CC# 9, Mode=CC Toggle disabled, No Special.  With LED color, when i selected drum pad color, the buttons changed also, The actual color shown in the inspector does not correspond to actual color I see. If I change the color of the Buttons, everything except the 8 faders change color too but only on the first change, after that I have individual control of the button.
    Master Fader - Same setup as Faders with CC#17
    So after some fiddling with color settings all seems to fine, so I save to device. To confirm that all is saved I switched bank, waited for editor to catch up then switched back, waited again then proceeded to check all was good.  Definitely not good!
    Drum pads - Pad 1 is ok, Pad 2, LED is set to note 66, pad 3-9 is CC#2-8,  Pad 9-17 is Note 74-81, Pad 18-32 is Note 17-31
    Faders - All seem fine although still wrong color.
    Buttons - The setting are correct, however pressing the buttons produce more weirdness in the editor Button 1 - OK Button 2 - Selects Pad 10, Button 3-8 - Selects Pad 12-17!

    At this point after several re-attempts and quite a bit of cursing and hair pulling, I thought best to quit, register on the forum and share my findings in hope for resolution, whether it be confirmation of the issue or that I'm doing something stupid. Either would make my day!!

    Thanks for Listening! 

    Richie

  • Alias8 with Reason

    Well, since there is no Remote Script for the Alias 8 on Reason, I am using the ohm64 script, which just doesnt work right. I would like to use the buttons as the Master Keyboard, where I can play a synth or a drum kit.


    At this point, since I am using the OHM64 script, only 6 of the buttons are working as "Keyboard notes", the rest are assigned to "Play, Stop, Record" which I do not need. I am guessing that is something that should be assignable, and everything on the Alias 8 is assignable but I just can't get them to trigger keyboard values like C3, D3, C2, C#2... etc..

     any ideas? 

    Thanks :)
  • 4K4F4B problems

    i know about the pink wire and the one above it #2 then 3-10 are the ones that go to things..
    -Correct
    Pin 3 is the first knob then 4-6 are the remaining three knobs in order.
    Pin 7-10 are the faders from left to right.
    http://wiki.lividinstruments.com/wiki/Omni_Board#Ribbon_headers_explained

  • 4K4F4B problems

    thanks mark,. hey, i would still like a diagram of the pins and what they go to,. i was thinking of making my own cable from the unused header,. but i will def take the one you are sending.. i know about the pink wire and the one above it #2 then 3-10 are the ones that go to things.. so on the 4k4f4b is fader 1 going to be wire 7?? am i at least correct in my learnings?? so is knob 1 wire 3?? knob 2 wire 4? and so on???

  • Brain Jr LED trigger

    Hi everyone,
    still not getting #2 to work. The LEDs are triggered when the first button is set to c-2 and local control is on. But since i got #3 working so the Drumpad of Live works perfectly with it the LED wont get triggered. On the Picture below you can see my settings. Maybe you can give me a hint.<br><img src="https://www.dropbox.com/s/zmw2rhr2vud35li/bRAIN.JPG">https://www.dropbox.com/s/zmw2rhr2vud35li/bRAIN.JPG<br>One other thing I would like to get to work is that when a midi Notes/patterns are played in Live that the LEDs get triggered (playback) without pushing the button!
    thank you for the quick help the last time.

  • Elements : 16B notes are triggering uncontrollably

    Thanks, Mark! 

    As your suggestion, the streaming is now STOP! Hooray!!! 
    BUT, another problem is both of my 16Bs some of the buttons still not working properly.

    NOTE#1 : The buttons that are circled in the screenshot are suddenly stop working.
    NOTE#2 : On individually tested, EVERY buttons on both 16Bs were working.

    image

  • Elements : 16B notes are triggering uncontrollably

    Hello everyone,
    I'm new with LIVID and MIDI code. Please,help me.

    My module list : 1st row  = 4E4F4B > 16K > 16B(1) > 4E4F4B
                             2rd row = 4F4B > 16B(2) > 16K 8F 

    The problem are
    1.My 16B(1) module notes
    are triggering uncontrollably in default setting.
      When I made some adjustment on 16B MIDI Setting some buttons has stopped working.
    2.16B(2) seems to replicated the setting from 16B(1).
    *Other modules are working fine. (I think) 
    NOTE : BrainV2 firmware updated to v178 
                Run on OSX 10.7.5

    image

    Thank you in advance!