Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Twitter

Base Scripts Not Appearing in Live 9.5 Prefefences

I updated to Live 9.5 recently, and now the Base Scripts are not appearing among the control surface options in Live's MIDI Sync preferences. Actually, the Base M4L script shows up, but not the Base script or the Base LE. I deleted my existing scripts from Livid and downloaded the most recent version of them, then re-installed. This didn't change anything. I've double-checked Live's MIDI Remote Scripts folder and the Base and Base-LE folders are where they should be.  Live does detect the Base hardware and I can manually map controls. Just can't load the script.

Using Base 01, with firmware updated and default setting just reset using the online editor. Ableton Live 9.5, Mac OS X 10.10.3 Yosemite.


  • Just wanted to report that this issue has not yet magically fixed itself. The Base scripts do not appear as an option for control surfaces in Ableton Live 9.5. 

    I have reinstalled the scripts from the Livid Apps page numerous times, and also manually installed the scripts from Github. 
  • Do you have more than one copy of Ableton Live in your Applications folder?

  • Hi Mark,

    Thanks for your Great question !
    I had the same issue and figured out that I had a Live Standard and Premium Version.
    The surface Control was appearing in Standard Version.
    I deleted it, and setup again the pkg file ...

    It works great on Live Premium 9.5
  • I have the exact same issue as efada, above, using a Base 2.

    I've had to downgrade to Live 9.2.3 to keep using Base. Is this a known issue?

  • I have only one copy of Live installed.

  • After you upgraded to 9.5 did you reinstall the latest version of the scripts?

    Ableton Live 9.5   Mac OS X | Windows

  • Yes, just like efada.

  • For me the OhmModes and OhmModes2, among others, don't show up as a Control Surface-option in Ableton Live 9.5. I've checked both the 64-bit-, and the 32-bit version. I got my OhmRGB yesterday, and have played around with the OhmRGB Editor a little (mostly just making pictures with the LED's), but I don't think that has anything to do with it not appearing as an option. 

    (Please redirect me if this comment doesn't fit in the post). :) 
  • edited January 2016

    Do any of the Livid control surfaces show up?  Which ones?  You're welcome to forward me your log.txt file and I can have a look to see what's going on:

  • I think I've figured out why some of us are having problems and others are not. At least I solved the problem on my computer. 

    On the Livid Wiki page for the Base Ableton Live Remote Script, the download link for the script is still taking people to the Controller Apps page, which has Live 9.2 as the most recent installer. This is also the link you're most likely to find when doing a Google search for the installer. 

    If you're on Livid's main site, on the Base integration page, there you will find the Live 9.5 scripts download link. 

    Once I found this installer, all of the control surfaces appeared in Live. Hope this works for the others! 

  • /facepalm/

    That worked.


Sign In or Register to comment.