Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Twitter

Issues mapping Brain JR to any software (Ableton/ Traktor)


I have four arcade buttons plugged into my brain jr becuase I just want to test and see if the thing is actually working. It's all plugged in, my computer is recognising it and so is the software (the indicators go off when I press the buttons- it is recognising the brain input) but when I try to map it to anything in Ableton it doesn't pick it up!

I've tried everything.

Does the button have to be note or CC to work with Ableton? What am I doing wrong? All I want is it to launch one stem.

Thanks in advance.


  • In your preferences in Ableton, under the MIDI tab, you should have "track" and "remote" enabled.

  • Open Traktor Controller Manager > Add new Generic Mapping Device > Set MIDI In-Port and Out-Port to your controller.

    You made it if you see the little blue dot (master section of the screen) flashing along with the button pushes.
  • Hi,

    I'm also experiencing the same problem trying to get the Brain Jr to communicate with Ableton Live.

    I have one pot attached to the 1st analog input on the brain. I can see the cc input going up and down in the brain software config so the pot is definitely working. I have both track and remote enabled in Ableton's MIDI preferences but still no MIDI input is showing up in Ableton.

    Is there anything else I should be looking out for? It seems the default config settings for the brain jr should be enough for Ableton to pick up the MIDI signals coming from the brain, so I don't know where I'm going wrong.

    Thanks for any help anyone can give.
  • What type of computer are you on?

    Can you share a screen shot of your MIDI preferences in Ableton?

  • Hi Mark,

    Okay, so here are the preferences in Ableton (I'm on a PC). You'll see that they are highlighted orange which I gather means Ableton isn't communicating with the Brain Jr properly. However if I turn the 'track and 'remote' buttons on and off again it seems to start working (I did the same thing yesterday but it didn't start working). 

    Any ideas why it wouldn't be communicating? Also attached the brain jr config just in case I've set it up incorrectly. Do I need to reboot Ableton everytime I change something on the config?


  • Keep in mind that on a Windows PC a MIDI controller can only connect to one software at a time. So close any other programs, and try Ableton again.

  • I think that's it, thanks very much for your help Mark - as you can tell I'm fairly new to this

  • All good! Let us know if you have any more questions along the way.

Sign In or Register to comment.