Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Twitter

Livid Code 2 - no led response

edited September 2013 in Hardware

hey hello,

first up, i extremely happy with the livid code, and if you guys would not have built that thing, i would be lost.
i am using it quite excessively with ableton 9 now since 4 months, and so far everything was perfect.
all started a week ago when i made a major reassignment for all the nobs, suddenly some leds and also the potentiometers started to act a litte wiggy (jumping chaotically in the value)
i realized that in the editor there was a problem by saving to a preset, when i renamed the preset, this problem got solved (allthough i had to give the preset everytime saving a new name otherwise the jumping would start again)
so i updated to the newest firmware, and all seemed good, but now, when i load the liveset it only updates the led values for active bank! 
and all the others stay blank, aslong as i turn them (but the value will jump to zero then) ore i press the "midi" button from ableton, then it updates them.
also if i turn on the computer the values on the active bank will change, but not on inactive, which means than then all the infos are incorrect later on.

please, PLEASE tell me that my bad feeling that there is something wrong with the internal flash storage is wrong, and that i just overlooked a simple setting that fixes this problem

i do not have long to a quite important concert and without my fully functional code i am fu**ed

grazie mille for your answers!

when i want to change the led ring number in the editor i get the message ""js: error calling function UI" in Max
and all the ledring numbers are automatically equal than to the one i changed

when i run the the firmware on on the code (both old and new) it sais complete, but in the log i can find these messages
** Skipping ff at 00000000 - not in Flash range.
** Skipping ff at 00000fff - not in Flash range.

same problem on a different computer :(


  • I am quite nervus, time is a factor :( Does that mean i have to buy a new one?

  • Are you using the online editor?

  • I did try it, no difference ..

  • Sent you an email - perhaps a video of the problem would help me troubleshoot.

  • hi there,

    I seem to experience the exact same issue. I have customized my Code to support more than one application at a time on different banks, I use aumhaa's Monomodular script in Ableton live and the automapped LED-rings of volume, pan etc. show the correct value but switch (the value) to zero first when twisted. I would basically have to manually readjust (take-over) all possible values within my set before I can rely on the feedback and this is of course no good. If there is a solution to this issue then I am definitely in need and would appreciate some help or advice. As for me I have an important performance coming up too and with this problem persisting I don't see myself using the Code live and I would have to do without many functions (great great shame it would be!).

    thanks in advance!!
  • What is the other application you're using?  Are you on Mac or PC?


  • hi aum—

    it's Reason I use in rewired mode. Bank 4 on the Code transmits channel 1 data, bank 1 provides my Reason remote scripts, banks 2&3 are customizable while bank 4 is deactivated for Reason in favor of Ableton and the Monomodular script of yours. But Reason isn't always running when I mess around in Ableton. I use the 'Encoders' plug-in of Monomod a lot, I've noticed that when loading a project the parameters assigned to the Encoders-Macros need to be re-affixed to them to follow their breakpoints every time. This I think is odd and isn't meant to be. Also, on loading a project, the values (leds) will all be blank before I switch to either one of the modes 2 (sends) or 3 (macros), they will only light up afterwards and then switch back to zero when I twist the knobs…
    As for the Monomodular script defines the encoders' speeds and overwrites my personal settings (I prefer 2x and 4x speeds) I messed with the script to correct this (it worked, though I am by no means python-experienced AT ALL). Perhaps this has caused some oddities with the led rings, but this is me guessing entirely yet again. this is how the encoder speeds are now setup in the

    hope this helps.
  • oh and it's a Mac I use.

  • when I deactivate and then re-activate LOCAL CONTROL in the Code Editor while Live is running it shows me where all the knobs are at (the actual values of the encoders of Code), and apart from those I have already turned, all LED rings are zero, which means that their current value is zero and they do not switch to their auto-mapped or assigned parameter, which they should of course, though on loading up Live the rings suggest they values are hooked up… something in the scripts perhaps sets them all to zero, although the LEDs suggest they are at the value of the assigned parameter. Just what could it be??

    Well, what has happened is that, yet again, my personal assignments to the Code's knobs and buttons has been overwritten by some chaotic values (no real systematic pattern here). I was able to load my bank setups and save them again to flash, but this seems to happen very often and one is being told that one shouldn't save to flash over and over again… I don't know what causes the overwriting of my setup every time — perhaps this has to do with the monomodular script whenever I make changes to the MIDI-setup in Ableton?
    It works now, but I can never be sure for long…
    thanks again guys for any help or advice
  • "Well, what has happened is that, yet again, my personal assignments to the Code's knobs and buttons has been overwritten by some chaotic values"

    I'm not clear on when this is happening? At what point do the assignments change?
  • I'm looking into this from my end, sorry for leaving you hanging.  You're setup is made more complicated by the fact that there are several semi-unique things going on;  not that it's "bad", but it takes a little extra effort to wrap my brain around what's happening here.

    The Codec script calls a factory reset when first loaded.  This could be messing things up for you.  You can disable it in the script by commenting line 391:


    I've added a new flag to the file for this in my working version so that it can be more easily configured by the user, and I'll add it to the next published version.  Let me know if this clears things up for you.
  • Hi Pete,

    it is just as unclear to me, though having said that, since I have avoided fiddling around with the MIDI Ins/Outs within Live recently it seemed to have remained stable… and whenever I did change a port in the MIDI/Sync window the Code seems to be affected in some odd way as described above.

    For the Monomodular Codec script to work, apparently the Code needs to be set to factory default settings. The bank default settings are to be found on my bank 4, where the Codec script works fine, even without resetting the Code altogether — which is a good and very useful thing indeed! It does however overwrite my bank 4 sometimes, killing the bank cycle and encoder speed buttons respectively (they are the two final Grid buttons to the right of the Code) and leaving me with one bank I can't make much use of. I think it has to do with the re-sending of the Codec script whenever I make changes to the MIDI settings in Live. If I could prevent the Code from being set to default settings (perhaps in the Monomodular or any other Code-related python files??), then these problems would not occur I don't think. But simply commenting out the respective line in the python files disables the entire script (as I said, I am yet unfamiliar with python commands).
    Thanks again for your help.
  • hey aum,

    we happend to have posted simultaneously so you basically gave me a very useful answer. I have commented the line you pointed out and after making changes in the MID/Sync Tab in Ableton, even after re-sending the Codec script, all personalized cc values and led-ring settings have remained the same — which is what is needed! I dare say it now works! At least from the Monomodular side of things my settings will now remain untouched and stable. Thank you VERY MUCH indeed for this piece of info.
    • Local Control gives me the values Ableton suggests
    • LEDs thus do not jump anymore but are currently where their parameter is at
    • bank cycle/encoder speed buttons still available
    • personal assignments in the editor are left unaltered

    Thank you, I can now focus on using this powerful device fully as it seems! Hope this was the final clue!

    PS@aumhaa: sometimes entering Monomodular by double tapping Gary leaves me with a blank screen, I figured this is because the Monomod-#ID of the device had changed from 1 to 3 at some point — is there a reference for the navigation through Mod devices on the Code? I don't know how to do that… i.e. switch from the screen for Mod 1 to Mod 4 etc. (...) thanks!
  • oh and another thing (sorry!!) :::

    when opening a project in Ableton the assignments of macros in the 'encoders'-Mod don't have the parameters affixed to them (green LED) so I have to affix all breakpoint-envelopes manually on start-up every time before I can set off with the sound morphing.… any clue as to why this may be? this doesn't get saved when I save the project. The only angle I ahve on it, is that perhaps parameters which are assigned to more than one macro a not affixed to it on start-up. Hence q#2: How can I remove parameters assignments from macros int he encoders-Mod?? is this at all possible?? sorry, but this would be important to know!
    Keep up the good work!
  • »when opening a project in Ableton the assignments of macros in the 'encoders'-Mod don't have the parameters affixed to them«

    seems I hadn't known about the 'save preset' function which enables the desired feature after all. Don't suppose assignments can be deleted though (not the breakpoints, but the parameters…).
  • First:  glad that got you sorted :)  I was hoping that was the root of the problem.

     is there a reference for the navigation through Mod devices on the Code? I don't know how to do that… i.e. switch from the screen for Mod 1 to Mod 4 etc. (...) thanks!

    I think what you're asking is how to switch which mod is controlled by the Code?  You do this by holding down Gary (=shift), and the top row of encoder buttons allows you to select which mod is currently selected for editing.  Here's more info:

    If that's not what you're after, you'll have to give me some more details.

    Re:  endcoders.  I've not been able to use any of my creations in a while in a practical way, I'm just getting back to them this weekend really.  Both the issues you're referring to (not being able to clear an assignment, and problems with recalling preset data)  are also issues I noticed, and they're irritating.  I'll be fixing it straight away ( soon as I can get to it), so keep your eye on my blog for some updates.


  • yes, it was the root of the problem and those exact issues have since not occurred, so great work!

    Concerning the mod navigator, it was indeed what I was looking for, hadn't noticed the instructions for the Code, so this works fine too! Great also, that the different Encoders-mods save the led-speed settings with them. You did state that assigning more than one macro to a parameter does work but results in only one being active with the breakpoints… I figure this also applies to more than one Encoders-mod in a set — so it isn't possible to control a parameter in different ways from different macros (of different mods)? I don't suppose there is a work-around in Ableton either…
    anyway, this has helped me a lot, thanks aum.

    @Lividpeople: I am having troubles again though with my settings of the Code, after having altered LED ring settings to save to different presets (the Preset selector doesn't find my Code presets btw…), the LED-ring CC-values have been altered again, ranging randomly from 36 to 94, 107, 108 etc., but not the values I had originally set. I don't understand this at all and changing it back is a massive rigmarole every time because the LED rings have all different settings according to their functions in Ableton — hence I cannot 'group' them but have to do it manually. I wouldn't mind doing that once but having to do it over and over again without it being predictable is unnerving. Any help on this here? Thanks in advance!
Sign In or Register to comment.