Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Twitter

Issues with encoders: Code

edited November -1 in Hardware
Hey I have owned a code for about a year now, and although I am very pleased with the design, I have been having some difficulties with the hardware. I just updated to the new firmware, and I am very happy to have control over the speed of the encoders, but I am still having some issues that I was hoping would be resolved with the update.

The issue I am having is somewhat random, and only happens with certain encoders. Some of the knobs, when twisted seem to stick, and continued twisting only causes fluctuation, up and down, of midi values. This is seriously impairing creatively speaking, and is a rather large headache. Is anyone else having these problems? Is this simply an issue of improper software setup? I have tried, as I said earlier, updating the firmware, and restoring the code to factory settings, but to no avail. Any input would be wonderful


  • Ok so this is a bit ironic seeing as ive been having this problem for awhile, but as I was messing around with the controller, turning all the knobs, trying to identify which ones were the worse, it seems that I somewhat alleviated the problem. The severity of the "sticking" seems to have decreased significantly just from giving the controller an extensive workout. However, I did capture some of it on video, but what I did get was pretty minor, comepared to what it was doing before the "workout." You should be able to see I am moving the knob in a smooth, steady motion, but the output in the software is choppy, and sometimes fluctuates slightly. This is not an issue of the particular software either, because I ran tests in the code editor alone, and had the same issues.

    The video was huge, so I just uploaded it to youtube here:
  • hmm I didn't see really anything wrong there. What happens if you change the speed of the encoders?
  • Maybe it's not entirely obvious from the video, but you can see the dry/wet knob in traktor jumping up and down as I move the encoder smoothly. Say I'm trying to change the rate of delay from 1/8 to 1/16, but instead it jumps backwards to 3/16, not exactly what you would want to happen if you are playing live. But yeah the speed is currently set to 2x and I used to run it at normal speed. The sticking encoder problem is still preasent at normal speed as well.
  • K so I unmapped it like you said, and now traktor doesn't send any output to the code. It has no effect on the spastic performance however, and the action is still a little jumpy. Keep in mind this is only on certain knobs, so maybe is this a hardware issue?
  • hey sorry about the late reply, I have been on vacation.

    the ones with problems:

    row 1: column 3
    row 2: column 1, 3,
    row 3: column 1, 3,
    row 4: column 1, 3, 4, 6
  • Hello,

    I too have experienced this issue quite often. From my testing, it never seemed to be related to the software I was using, since sometimes I could re-create the problem immediately upon plugging the Code in before I opened any software.

    I do a lot of work with Max for Live, and at first I had thought something inside Max/Ableton's MIDI data was causing the lag of knob values updating, but from further testing it definitely appears to be the code hardware. The other dead giveaway there is a hardware problem is that some knobs when I turn counter-clockwise to a zero value, the value does not always sit at zero and sometimes "skips" back up to a 1,2, or 3 CC value. You can imagine the headache when I have to try two or three times to get a knob to stay at its actual zero value.

    Moon, I will make a video right now outlining both the zero skipping and the knob turning data value lag issues I am speaking of.
  • Here are 2 video examples I recorded today demonstrating the both the jittery encoder values + jittery zero value issues. They should be fairly obvious in the video.

    In the second video I am turning the encoder slightly faster than previously, where the issue is much more obvious:

    Note that I only had the Code plugged into my Mac Mini via USB without any MIDI software running.
  • That looks like a firmware update issue. Did you update the firmware yourself?
  • Hello, I have exactly the same problem as ziggomatic and it is very unfortunate because it makes the controller unusable. I'm on mac 10.6.8 and I made firmware update myself few month ago. I Really would resume normal operation because this machine is terrible otherwise.
  • Jay,
    I did not do the firmware update myself, I sent it to you guys last year to have the firmware updated, after we came to the conclusion my Code did not have a bootloader so I was not able to do the firmware update myself (ticket #310837).

    It's really intermittent which encoders exhibit this behavior, some seem to be fine and always work great, and others show this behavior on and off. It also may have something to do with the fact many of the encodes have different resistance levels when rotating. Some have a nice medium-heavy resistance, but others rotate with little to no resistance. Seems the lighter feeling encoders might more often exhibit this jittery value behavior.
  • Hmm so this only happens some of the time? On the same computer?
  • It happens all the time but like I said varies between different encoders, regardless of which computer/OS the Code is plugged into.
  • When you updated did you make sure the "aloow configuration word programming" was checked?
  • I'm having the exact same problem with a used code I just purchased. I haven't yet updated to the latest firmware though (code editor reports it as 0 1 0 0). Is there a decent chance it's a firmware issue?

    None of the green lights for the encoders indicating max value ever light up either, but I'm not sure if it's related.
  • Jay,

    As I said above, I DID NOT update the firmware myself, Livid Instruments did.
  • Please fill out a ticket here we'll see what we can do.
  • hi

    same problem with mine...

    did you find a solution to fix it ?

    could it be a contact failure ?

  • hi...

    How can i remove caps ??

    it is really fixed and i am afraid to do something wrong....

    Can i put deoxit in without removing anything ??

  • Did anyone ever figure this out? I have a code thats become completely unusable, nearly all the encoders have a high amount of jitter. It's only 16 months old. All the encoders on my 8 year old Behringer still work perfectly, and it was less then half as much as the code, and has never been serviced.

  • If you are referring to how to get the encoder caps off:

    I like to wrap a bit of thin cloth around the base and pull up on the cloth at the same time as I pry up with my finger tips on opposite sides.

    Do you have smooth or detented encoders?

  • I just purchased a code from a friend, and He was using a mac and claims he never saw this issue.  I'm seeing this issue on my PC, and am wondering if anyone ever figured out what the problem was?

  • An encoder has almost 100 very small switches inside of it.
    Over time they often become Oxidized and less responsive, or the lubrication gets worn out and the switches don't make as good of contact as they should.

    We recommend using DeOxit F5 FaderLube about once a year to keep your encoders in top condition.
    It will get rid of the grit, and smooth out the spin of your encoders.

    To apply, first make sure your controller is unplugged.
    Then, you must carefully remove the Rubber Cap from your encoder (Carefully because you do not want to pull the shaft of the encoder out!)
    You will see a small opening around where the Encoder's shaft meets it's base.
    Using the WD-40 style straw that comes with the FaderLube, spray some inside, twist the encoder in both directions a few times to spread the FaderLube around, and wait about 30-minutes for it to DeOxidize.
    Then, try your encoder.

    If you notice improved response, but it is still sub-par, a second treatment may be applied the following day.

  • this is exactly how my problems started
    first this jittering - which i could solve by saving a new preset.
    than later the code did not recieve ANY midi messages in inactive banks.

    i did all firmware updates, tried web editor, different sofware and computers.
    that changed nothing

    it basicly was broken than, i let it ship to a service place in germany, they said that the internal storage is broken.

    my thread:

    they still repairing it since 1 and a half months, so i had to buy a new one, cause the code is basicly my main instrument.
    i thought problem solved, but with the new one, from time time, it AGAIN receives no midi messages (!!!)

    this problem scares me extremly, like i said its my main instrument and if this happens on stage i can just pack up and go home ..
    can i be that unlucky that i get 2 deffect hardware pieces in a row??

    here is something that happend both with the "old" (3, 4 months) and the new code and i think it might be either the indicator of the broken memory ore that there is something wrong with both the normal software editor and the online editor:

    after chaging a lot in the editor (adding banks, changing from volumes to eq etc.., midi numbers, you know.. make it fit) 

    i can change the midi numbers from buttons,leds whatever - BUT the numbers from the ledrings will all go back to 0 (all of them) after switching back from another bank.

    please, livid, FIX THIS 
    i LOVE the code, and my whole music is built arround that that thing already.. 
    i need to it working flawlessly !!
  • Again, I'm not entirely clear what the problem is. Can you post a video example of the problem and how it occurs in your setup?

  • edited January 2014

    Add me to the list...for the last few months I have been experiencing this behavior as well. The encoders get sluggish and have brief stutters causing a break in fluid operation. Hopefully this is something that can be fixed via software. Or perhaps it was the result of a firmware update, I may try rolling back further if that's possible. I have been code owner for about 18 months.

  • edited January 2014

    I can confirm that DeOxit Faderlube F5 completely solved this issue for me.  My livid code works 100% now after 1 application. 

  • edited March 2014

    Today I applied DeOxit Faderlube and it has appeared to fix the problem for me as well. At least as far as I can tell right now. Generally the controller feels more reactive again without stuttering. I had my doubts...but now I know that a little maintenance is required to keep things running smoothly.

  • hello, i have a problem with one of the encoders.

    how can i open the code to verify what it is?


Sign In or Register to comment.