Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Twitter

CNTRL:R White - Steppr Colours Problem

edited January 11 in Hardware

Hello all,

I recently obtained a CNTRL:R White.
I am under ableton 9.7 and Max 7.3.2 and I installed all the Remote Scripts for the CNTRL:R which are working and are recognized by Ableton (took me 3 hours to find the correct version but all fine :D)

I started using the Steppr to create my drum patterns, I followed the guide and I made it work.
Nevertheless, I experience few problems, for example, when I play a sequence, the 4x4 pad does not lit accordingly to what is played.
Only the current sound that I am manipulating is lit.

Furthermore, when I make a sequence, the buttons of the two bottom rows are always lit and I do not see the step timer pass (only when I have the 16 buttons pressed and sequenced, the colour changes (blue for the 1st, 5th, 9th 13th step and dimmed white for the rest)

When I want to mute an instrument in the drum rack, the button remains lit. I had seen in videos for CNTRL:R black that it was the opposite, the button is in normal state off and it lits when you mute an instrument in your drum rack and that you also have the steppr moving in the far bottom button row.

Is it a firmwire thing ? Or just with the new Remote Scripts that this is not possible? Is it the Max Version that should change?

Anyone had this thing with CNTRL:R White edition? I tried to change the colours from the Map.py file but I cannot manage it for the Steppr, I cannot find the right line for it.

Any info on that?

Thanks in advance

Comments

  • Hi Filoxenos,


    Please double check that you have the correct version for your controller.
    For newer versions of Ableton Live the scripts should be installed manually.

    http://wiki.lividinstruments.com/wiki/Install_Ableton_Live_Remote_Scripts

    Current downloads support v9.7.5 and newer.

    Older downloads are available at the bottom of that page.
    9.6.2 and higher require manual installation as described in the links above, whereas before then, we have installer packages.

    If that does not resolve the problem,
    it may be a configuration issue (either device firmware or Ableton Live configuration).
    You may try running a 'Factory Reset' (labeled as 'Default Settings' in the Online Editor documentation) in the Online Editor to make sure that you have the standard Cntrl:R settings.

    You might also try a fresh Ableton Live Set, and see if the problems persist there.
    Previously mapped MIDI Messages done by the 'MIDI Learn' feature of Ableton could be interfering with the operation of the script.

    If you continue to have these problems,
    can you post a screenshot of your Ableton Live's MIDI Settings Window?

  • Hello Moon,

    Thanks for getting back to me.
    I managed to manually install the Remote Scripts, with the installer it did not work.

    I will double check the version that I have that at 90% it should be fine.
    I will try doing a Factory Reset and I will get back to you, and I will post a screenshot when I get home.

    Thanks in advance :)

  • edited January 16

    Hello Moon,


    So, the colour thing & the sequencer thing has been repaired after I tried Default Settings in the Online Editor. 
    The machine seems to work more smoothly.
    Nevertheless, some things are still not working as intended (I started a new Ableton Template with no MIDI mappings - Cntlr:r was the only device connected to Ableton when I tried it again):

    1) When I have DrumSteppr and Synthsteppr in the same Ableton Live Set, CNTRL:R stays on and controls only the second Steppr that I introduced to the set. Is this normal? (of course each Steppr is in a different track and introduced as it should be, first the steppr then the instrument blabla.)

    2) The knobs on the upper-right part that are supposed to treat the EQ Three, control indeed the EQ Three when it is the only device in a track. When I introduce an instrument or a Steppr, the knobs control 3 random parameters of the instrument. Is this normal?

    Thanks in advance.
  • 1) The CNTRLR will follow whatever you have selected in Live.  It should assign the controls automatically when you select the device in Live's GUI (it will show a little hand next to it).


    2) If I remember correctly, the EQ functionality only works when the EQ device is the first one in the track.  I'll have a look at this when I get a chance and try to get back to you.....

    a
  • edited January 17

    Hello Amounra,

    Thanks for getting back to me.

    1) Let's say I have DrumSteppr in Track 1, then in Track 4 I put SynthSteppr. When I am in Track 4, it controls SynthSteppr. When I use the knobs to get back to the Track 1 and control the Device DrumSteppr, CNTRL:R with the knob M4L enabled, it still controls Synthsteppr of Track 4. I cannot control DrumSteppr anymore of the track 1 even if it selected. It is "stuck" on Synthsteppr of Track 4

    2) EQ cannot be in the first place when I put an Ableton Instrument.

    Bonus extra point :
    3) In DrumSteppr Mode - I do not see the pad lighting as my pattern is played, as we see it happens in this video in 56:26

    ()

    Any info on that?

  • I'll have a look tomorrow when I'm at home and have my CNTRLR for testing.  Honestly, it's been some time since I looked at this, so its possible something has gotten broken, but everything worked the last time I looked.


    One thing I can tell you, though, is that I won't be able to help with older versions of Live/Max.....I only keep current builds around and its very time consuming to try to backdate my installation for support purposes.  So first thing I'd do if I were you is update to Live 9.75 and Max 7.34, then update the m4m7 package from my GitHub repository and replace the Python scripts in your Live app bundle.  You might find some problems you're finding clear up with the current build, if you're not running it now.

    If you need any help with updating, I'm glad to oblige...

    a


  • Aight, Ill try updating and I will let you know my brother, thanks for the information, you are a true knight of the CNTRL:R legacy.

  • edited January 17


  • edited January 17

    UPDATE: I just updated everything as you said, I downloaded all the new Scripts, I connected CNLTR:R with 9.7.5 Live 64 bit and Max 7.3.4 and unfortunately the same problem persists. It's as if I can only have one "xSteppr" per live set, otherwise the cntrlr bugs and cannot seperate and distinguish the two "stepprs" in the Live Set. I have DrumSteppr 1.5 and SynthSteppr 1.4, dunno if they are the most recent ones.

  • Not sure of version number, but the most current ones are the ones from the m4m7 repo, they should be in ~/Documents/Max 7/m4m7/patchers/Mod b997/.   Make sure you've followed the instructions in the m4m7 readme about where to put the package so Max knows where to find the files.  Let me know how it goes ;)


    a

  • edited January 18

    I just checked the versions in repository, and although I'm using the AumPush script (I don't have a CNTRLR to check with right now), both the SynthSteppr and DrumSteppr are working as they're supposed to, they switch between instances without a problem.  I can't imagine a situation where the CNTRLR would behave differently (as the mod portions of the Python scripts are fairly identical and use the same core), but I will double check later when I'm home with CNTRLR just to be sure for you.


    One thing that could conceivably be an issue for you:  there is a 'lock' button on the CNTRLR that will prevent switching mods when it is activated, but I don't think this the problem you're describing.  Just in case, you could try toggling the modLock button, which is accessed by going into deviceSelectorMode (top left encoder button) and pressing the bottom right 4x4 grid button.  Again, though, I doubt that's what's going on.....I suspect this is just a case of using out of date files.

    FWIW I'm working on packaging up this stuff in a new Max Package for the impending release of Live 10 (just so everything is in one place and its easier to understand what to do to get things working), but honestly the Stepprs were a collaboration, and very messy, and VERY hard to edit at this point so there won't be any changes beyond any small incidental fixes for Max8 when it's released.  You might want to check out "Hex" (also in m4m7 repository), as it performs the functions of both stepprs plus a lot, lot more, and I will continue development for it through the foreseeable future.  

    Docs are somewhat out of date, but all the essential info is here: http://www.aumhaa.com/wiki/index.php?title=Hex

    a

    edit::  haha, I guess we already corresponded about this some time ago (via Stephan Bodzin).....cheers :)

  • Ok....so I can confirm your reports.  I'm getting the same problem here.  I'll get back to you when I have a solution.....really scratching my head here though.


    a

  • Should be fixed now, I've pushed a new build to GitHub.  Just download the package and replace your current one in the Max directory, there's no need to do anything with Python files.  Thanks for bringing this to my attention, somehow I totally missed this problem the last time these files got updated.  And, of course, let me know if you find more problems, as it could be an easy fix like this one was!


    a

  • Man you are a god :D 

    It is fixed yeap! 
    What about the EQ thing? 
    Got any insight on this? 
  • EQ assignment to the right knobs is dependent upon setting a flag in Map.py to true, line 25:


    EQS_INSTEAD_OF_MACROS = True  #Maps right dials to EQs when "True"

    If you don't make this change, the script will use the default behaviour, which is to assign the knobs to the first three macro controls of the first rack in the track.

    This is working for me, it selects the last eq device in each track, and assigns three knobs (vertically) to the first three gains of each eq on the four tracks available in the session ring selection.

    a

  • Amounra,


    Thanks a lot for your time mate.
    This has been fixed as well, I am grateful for your help.



Sign In or Register to comment.