Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Twitter

Livid CNTRL Scripts V2 Questions

Hi everybody, 

I decided to upgrade to the V2 of the Livid CNTRL Script. It's really nice. But I have some questions : 

 How do you mute a single pad of the drum rack ? Like the upper line of the sequence used to do in V1.

And, when I create a sequence with the livid hardware. The drumSteppr doesn't record step anymore. So it's all in the livid hardware. But that's causing some troubles, like the impossibility to use presets. So how can I make the Stppr simultaneously works with the livid hardware ?
and it's the same problem with Accent, I did not find the way to control it with the livid. 

Thanks, 
Alvynn. 

Comments

  • (Ableton 9.5 Suite)

  • So I updated everything. Ableton 7.1, new scripts. But I have the same problem. the livid controller is working all by himself and the drum steppr record nothing. 

  • Sorry for the delay in getting back to you Alvynn, I'll try to answer your questions later tonight or tomorrow when I have my CNTRLR next to me.  Accent and Stepprs DO work with new script, you have to push one of the top encoder buttons to enter "mod-mode" while the device is selected.  I believe its the one on the top-left.


    a

  • Thanks for your answer. I found how to enter in the stppr mode, it’s the third top encoder. 


    I will be more precise about the problems I met : 



    • When I use DrumStppr with the drum rack, the mute buttons of the stppr work perfectly. But if I add Accent in the same track (because I use both in the same time) the drum rack doesn’t respond anymore to the mute button of the stppr. 


    • When I’m in the DrumStppr mode, I can’t use the parameters repeat, groover random and rot size because the top encoders stay for the main script function which is switching between instruments. 


    • Is there a way to switch between « Rules » and « mutes » in the drum stppr without using the mouse ? Like making it midi. Because we can’t make a 32 step sequence in the drumstppr.


    • And finally, is there a chance that we can have the highlights for the 4x4 pad back? It helps a lot to quickly know which sample is running.  


    I’m using Ableton 9.7.1 and the new script on your git. Except this, it’s a really good controller.

    Thank you. :) 


    • When I use DrumStppr with the drum rack, the mute buttons of the stppr work perfectly. But if I add Accent in the same track (because I use both in the same time) the drum rack doesn’t respond anymore to the mute button of the stppr. 
    Are you sure that you've focused the right device?  The controls will migrate to whichever mod-device you have selected....

    • When I’m in the DrumStppr mode, I can’t use the parameters repeat, groover random and rot size because the top encoders stay for the main script function which is switching between instruments. 

    Pressing shift (second encoder) should allow access to those functions.

    • Is there a way to switch between « Rules » and « mutes » in the drum stppr without using the mouse ? Like making it midi. Because we can’t make a 32 step sequence in the drumstppr.
    I don't believe there is.

    • And finally, is there a chance that we can have the highlights for the 4x4 pad back? It helps a lot to quickly know which sample is running.  
    Probably not.  These patches are VERY old now, and editing them invariably causes things to break.  I'll try to have a look and see if there is something in the javascript that would accommodate this, but if I remember correctly it was in the Max patch and I don't have the 4 hours of frustration available to make the change at the moment ;)  Also, it bogs down the speed of the patch considerably, and would lead to more frequent crashing/glitches.  It's simply too much data at times being passed between Python and JS.


  • Perfect ! Thank you. 


    The mute stppr/accent bug shows when I start a project I load. The mute buttons doesn't work (And I'm controlling stppr). I have to delete accent from the track, and add it again. Then the mute buttons will work again.


  • Ok, thanks for the details.  I'll try to have a look tomorrow and see what's up :)


    a

Sign In or Register to comment.