Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Twitter

Digital buttons on the Brain Jr.'s analog block

I need a total of 20 digital buttons on my setup.  I saw this video:  where this dude hooked up one side of the button to the analog +, and on the other side he attached 2 wires, one going to the #, and the other connecting to a resistor and then to the -.

Then I found this discussion in the forums: which references the "button mode" setting in the Brain V2 Configure utility and states that I'd need a 10k resistor.  I did a little math and figured that 3W should be the right resistor for the job, and I wired this up in my rig.  However, It didn't seem to work once I was trying it out in the Config utility.

So, I cut off the resistors and wired the buttons to the + and - on the analog block and set those analog lines to "btn" in the Config, and I turned on the "flip" so I get 127 when I press the button and 0 when I let it up. I've got IDs 3,4,5, and 6 (MID notes 67, 68, 69, and 70 respectively) in the analog block set this way.

But, when I press one of the buttons the blue LED on the Brain JR goes out as long as the button is held (not sure if that's a problem), and the MIDI input shows activity for all 4 notes, no matter which button I press (e.g. if I press button 3, I get "note 70 127 ch 3, note 69 127 ch 3, note 68 127 ch 3, note 67 127 ch3 and upon release I get note 67 0 ch 3, note 70 0 ch 3, note 69 0 ch 3, note 68 0 ch 3) 

Is there a way to get the Brain Jr. to handle these as discrete notes for each of the buttons?

Thanks for the help - I'm pretty new to all this and it's been fun working on the little mysteries.


  • Hi unclenoah,

    When the blue light goes out, it is indeed a problem.
    It implies that one of the voltage sources is being connected directly to ground.
    This shorting will trigger pretty much every connected Analog Input whenever it happens, so you will need to update your connection.

    The video'd system of connection does work.
    Perhaps you misunderstood part of the hookup when make your initial connections.
    Let me detail it here for you:
    Voltage to one side of the button
    Analog Signal to the other side of the button
    10k resistor connecting Analog Signal to ground.

    Let me know if I can help you more with that.
    By the way, you only need a regular old 1/8 or 1/4 Watt resistor for this application.
    Though, having a 3W resistor will not hurt anything.

  • Ok, i got everything wired up exactly as described and it's still not working right for me. I'm finding that the button signal works about 1 out of every 50 button pushes, and the signal is sent very slowly - it lags the button push (and release) by somewhere between 2-5 seconds. The other 4 pots hooked up to my analog inputs are sending just fine with no lag. I tried setting the buttons to "pot" and "btn" just in case there was an issue there, but it didn't seem to improve the situation. I really don't understand what's going wrong but it seems like I'm close to the solution. Any help is appreciated!

  • Hmmm... there may be something else at play.

    I have a few questions for you, to help narrow this down.

    Have you find that the blue light is no longer going out?
    Do you have any capacitors hooked up to these 'buttons as analog inputs' circuits?
    What value of pull-down resistor are you using?
    Can you take and send me a picture of your wiring for one of the buttons?
  • The blue light is no longer going out

    I do not have capacitors hooked up to the buttons
    The resistor I'm using is 10K Ohm 3W
    I've put pictures (they're big, but I figure it lets you really get in there) and descriptions up at
  • Okay,
    Thanks for the images.
    The wiring on the button looks good.
    (Ground on Outside, Signal in the Middle, Power on the Inside, Pull Down in the right position, 10k is a good value)

    Judging by your results, and all of the information above, the only conclusion that I see is that the Power or signal connection is loose on one end or the other (red or yellow).

    Have you tried a different analog input?
    Have you tried wiring the button as a digital input, to make sure it's working like that?
    The answer to those two questions should really narrow it down.

  • I've tried all four of the buttons on various analog inputs with the same behavior.

    I've tried all four buttons on one of the inputs on the digital block and all four buttons worked.  So I know it's not a mechanical problem with the switch in the buttons, nor is it a physical problem in the wiring on the buttons.

    I'm completely lost on what to do with this.  This seems like it should be so easy to do, and from the youtube video is looks like it's as simple as falling off a log, yet I can't make it happen at all.

    At this point, I'm willing to pack up the controller and mail it to someone who knows how to work this miracle so they can lay hands upon my box and see if they can't make it want to behave. :D  As always, any help or direction is much appreciated.

  • edited June 19

    Figuring that the problem must be related to the resistors I was using, I did some un-soldering and re-soldering, and replaced what I had with 10K Ohm 1/8W and put everything back together to see if things would work differently.

    Sadly, there's no change to the behavior I'm getting. 
    Since what's going on seems s crazy, I decided to make a video to document it and show what I'm experiencing - maybe someone will see something here that will stand out to them as an obvious error that I'm making:
    Could it possibly be that there's some kind of defect in my Brain Jr. board itself that is preventing this from working? It seems like all of its other functions are AOK. 
    I really appreciate any help that anyone could extend to assist in solving this mystery. 
  • I couldn't get that video to play. I'm not sure why

    It seems like your pull-down resistor is not functioning.
    Since it's in button mode, it will only send a message with positive value after it's sent a '0' message, and those zeros are not coming quickly!

    Do you perhaps have the resistor on the wrong side?

    Button Side 1: Gets +V

    Button Side 2: Gets Signal Pin, and Gets Resistor Side 1

    Resistor Side 2: Goes to the Ground Pin

    I bring this up because if you put the pulldown resistor between +V and Ground, then you could get the results that you described.

  • OK - I've triple-verified that I've got the button sides wired as described above.

    I've put up a new Web page with pics of the new resistor setup in case there's something I'm getting wrong that you can figure out visually (Note: I've moved the buttons to analog spots 13, 14, 15, and 16 just to make it a little easier on me):

    Sorry my video didn't work well for you - I've uploaded it to YouTube, and you can see it at:

    (There's also a link to the vid embedded in the Web page listed above)

    Thanks again for all the help. I feel like I must be making some kind of amazingly simple error here, and I just can't figure it out.

  • Your wiring looks good.

    When you set a button in 'pot' mode it still doesn't send any messages, right?

    It seems unlikely, but perhaps the button has some kind of internal diode. Have you tried reversing which side is power and which side is signal?

    Another thing you could try is a simple wire test.
    Putting one end of a wire in an analog signal pin that you want to test.
    Now put the other end of that wire in the '+' side. Does it output value 127?
    - Now take that end out, and put it in the '-' side. Does it output value 0?
  • edited July 9

    OK, this is really starting to get Twilight Zoney on me here. 

    I get the same behavior if I'm set to pot mode.

    After reading this last reply, I plugged everything back in a tried again, and for some absolutely unknown and unexplainable reason, I got consistent, timely response out of note 77, but not the other three.

    I do not think there's a diode in the buttons - these are standard Sanwa arcade buttons, and opening them up all I see is the switch assembly.

    I decided to test the buttons on the digital block one more time, and here's where it gets strange again. With nothing plugged in to analog 13, 14, 15, 16, I unplugged digital 1 and plugged in my "mystery" button's red and yellow (no resistor) ends into CC1 on the digital block. The Brain Jr. Tool reflected activity on note 77, 78, 79, or 80 (inconsistently) during the different tests, only upon the first button press, and then reflected only the on and off of CC1. All buttons reflected on/off on CC1 with the wires in both directions. So I don't think there's anything wrong with the buttons or the wires.

    I did the wire jump test as described on analog 13. 14. 15. 16 (note 77, 78, 79, 80 respectively) and when I have the wire plugged in to the # on 12 (note 77), if I get my hand within about 2" of the other end of the wire, I get massively repeating on and off data on notes 77, 78, 79, and 80. When I finally plug the wire into either the + or the - this massive repeating of note data stops, but so much has flown by that the data I see isn't very helpful. 

     BTW, I was wearing a grounding strap which was attached to the ground on my powered-on DJ mixer, but I found the same behavior when I was ungrounded as well. 

     I know this sounds completely insane, so I made a video of it:

  • I'm not sure if this was ever resolved, but I am having the same problems as unclenoah. When I try to use the btn mode with the analog headers I can't get any response. It even fails when I do a direct wire test. I can get response in the tools window in pot mode though.  It makes me wonder if the brain jr may be malfunctioning.  I have two brain jrs and am using momentary switches with 10k pots on the analog headers on my 2nd brain without any problem so I at least know my wiring is correct.

    Any suggestions? The unit is several years old and slightly abused at this point
  • Slightly abused may have been an understatement... Im pretty sure I messed this brain up at some point. I think I'd best just replace it.

  • Hey Tor! I'm glad to know at least I'm not alone with this issue. I've not been able to resolve it, and I've been thinking I'm just going to reconfigure my controller design to include more analog controls and forget about trying to add these additional digital buttons. If you figure any of this out, please let us know!

Sign In or Register to comment.