Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Twitter

Drumsteppr mutes buttons not working with Cntrlr

Hi everyone,
this is my first post so sorry if I make any mistake.


I've been searching in the forum for a while for something related to what's happening to me but can't find any suitable solution even there's no specific thread but I guess someone is having the same problem.

I've been using the Drumsteppr maxforlive device for a while with my Cntrlr and I was very happy with it -using Ableton 8 and first version of the remote script.
But now, for some project reasons, I've moved to Live 9.6.1
I've successfully installed the Cntrlr2 remote script 9.6.1 version (I had to use Pacifist software to extract the files manually because the installer was crashing everytime) and I can use it with Ableton with no problems...in fact I'm very happy with it.

Then I add the Drumsteppr and select the device to enter the sequencer mode.
All works fine except the mute section.
The leds are yellow on my Cntrlr and toggling them also updates the device but I cannot see the change populated to my Drumrack so in the end the mute/unmute is not happening.
Is quite strange because other things are working perfectly.

I've followed all the steps to configure my Drumrack properly.
I've tried prefab Drumracks and I've tried manually and also downloaded the project templates but the same thing happening.

This is my system configuration so far:
- OSX 10.10.5
- Livid Cntrlr (white edition) with the firmware updated to the cntrlr_123 version hex file
- Drumsteppr v2
- Ableton Live 9.6.1 (32bits)
- Max 6.9.10 (32bits) also tired Max7 with the same problem

I've also tried to downgrade to Live 9.2 version but then not only the mute problems...selecting a sound with the 4x4 grid makes no changes on the matrix knobs.
As a quick note, with the last version, I can use the two bottom encoder rows of my Cntrlr for changing each sound params but cannot access the third row...it seems like is displaced and the top encoder rows are still only working for navigating the session.

At this point I don't know what else to try and cannot figure out if is an script or device problem.
Any help will be appreciated because I need to use my Cntrlr as before asap...the mutes function is quite important for playing with my live setup.

Thanks a lot for your time,
Adrià.

Comments

  • I update with some other thing that I think is not working properly compared to my previous setup.

    The 4x4 grid is selecting the proper sound from the drumrack but unfortunately the leds are not flashing when a sequence is added so I cannot visually see which sounds are being played.

    This is less important, for me at least, than the problem related with mute buttons but will be a very nice to have feature.

    Today I will try to install the last version of the remote script for Live 9.6.2 and see if works.

    Thanks.
  • edited July 2016

    See the sticky post at the top of the forum:



     I've included instructions for getting the most current/working versions of the scripts and stepprs.

    a
  • Hi again amounra,

    after several tests with the github repo scripts you mention in the post (the sticky one at the top) I got the same results, event worst.

    First of all only Livid_CNTRLR script is appearing in my Live 9.6.1 and I've copied the following folders into MIDI Remote Scripts:
    aumhaa
    _Mono_Framework
    Livid_CNTRLR
    Livid_CNTRLR_2
    Livid CNTRLR_v2
    and checked I'm using the latest DurmStppr m4l device with version 1.4

    Also I've tested with Max6.1 and Max7 engines but the same result, the mutes button are not affecting the drum rack and only the last 2 rows of push button matrix are affecting DrumStppr params (the first one is still affecting the transport or user modes).

    What I'm missing or doing wrong?

    Thanks a lot!
  • The only script that is maintained and working with current versions of Ableton Live 9.6.2 is the Livid_CNTRLR_v2 script.  If you're using earlier versions of the script, they aren't going to function properly.  I believe the problem you're having is that you are using the wrong version of the scripts.


    a

Sign In or Register to comment.