Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Twitter

New MIDI Remote Scripts for Ableton Live 9.76

24

Comments

  • @themactech:


    Thanks for the update!  I've been unable to work on 9.7 yet because of these 9.6.2 concerns, so its good to know things haven't gotten completely broken there.

    BaseLE is a custom script used by Laura Escude.  I honestly don't remember what the differences are, you should be able to Google it though.  
    All the m4l scripts were made by Peter Nyboer, they have no functionality other than exposing controls via to MaxMSP via m4l.  They're really no longer necessary, as I added better override support to the newest scripts after they were produced.
    If you're interested in customizing the script to your own needs, I'm always available for commissioned work.  Usually rudimentary changes don't take me very long (and thus aren't too expensive).  PM me if you'd like ;)

    a


  • Hi @amounra

    Thanks for this update.
    It seems most of the functionality working. Few things which is not working for me:
    1) Once I'm in midi track would like to record new midi clip, press record clip on cntrlr 4x4 grid then press shift, playing notes, press shift to get back to clip launch mode to stop recording and playback - cntrlr is getting stuck on playing midi mode.
    2) I can't scroll between effect racks on master track for some reason.
  • *Sorry not "shift" but "session/sequence" button

  • Hey Wallas, just getting back home from a festival....I'll have a look at this later this week, thanks for the help!


    a

  • Hi there! 

    Are there News for Livid DS1 and Ableton 9.6.2? 
     ...in the "Control Surface" section I can not see the controller! I tried to update the script but does not give me anything!
  • @matleo1989:  If you'll read through the rest of this thread, there are instructions about Live 9.6.2 in my post from July 29th.


    a

  • One more issue, when I'm working in clip launch mode, and launch a scene with session/seq button + Play it just stop the session.

  • @Wallas:  swamped, but haven't forgotten about you.  Just now getting around to working on 9.7b.  


    a
  • edited September 2016

    Hi everyone, specially amounra.

    First thanks a lot for your work and help into this forum.

    Few weeks ago I opened a thread related to CNTRLR and Drum Steppr with Live 9.6.1 and the official installation files available on the website (by the way, I had to use Pacifist because the pkg installation was failing each time).

    After following the latest instructions on this thread the problem is almost solved.
    The main issue was that Drum Steppr mute buttons were not affecting the drum rack and also the 4x4 matrix buttons were not correctly mapped.

    As amounra says, following the instructions here https://github.com/aumhaa/m4m7 solved the big problem.
    Quickly:
    1. Make sure to have Live 9.6.2 and Max 7.2.4 otherwise will not work
    2. Install the remote scripts and the proper controller scripts (if any) + Max 7 packages
    3. Re-launch live and set up everything under preferences

    The CNTRLR_v2 script is properly working and Drum Steppr mute buttons are working as did on my Live 8 setup.
    The only things I'm missing are:
    - in the Steppr mode with the CNTRLR the sounds that are currently playing are not highlighted (so I have to take a look at the screen)
    - the 4x4 matrix buttons are mapped but only working the 2nd and 3rd rows (the 1st one is setted to the default v2 script actions)

    Would be nice to have a fix for that but meanwhile I'm pretty happy with it.

    Great work and effort.
    ¡Thanks again amounra!
  • There are some minor adjustments I'll need to make when 9.7 comes out, I've already began sorting them.  If any of you are running the beta and would like to test things out, let me know and I'll branch the github repo with a beta commit containing the updated files.


    @Wallas:


    1) Once I'm in midi track would like to record new midi clip, press record clip on cntrlr 4x4 grid then press shift, playing notes, press shift to get back to clip launch mode to stop recording and playback - cntrlr is getting stuck on playing midi mode.

    I can't reproduce this.  Maybe post a video of this happening if you have time and are still experiencing this.

    2) I can't scroll between effect racks on master track for some reason.

    I know about this, and will be hopefully have a fix for 9.7 update (I may have already fixed it internally, I noticed this last week ago when working on something for a client).

    One more issue, when I'm working in clip launch mode, and launch a scene with session/seq button + Play it just stop the session.


    I can't confirm that....can you give me any more details?  It's working fine for me....


    I'm glad you're making progress! 

    - in the Steppr mode with the CNTRLR the sounds that are currently playing are not highlighted (so I have to take a look at the screen)

    Unfortunately, we removed this functionality long ago (probably when Max7 came out) as it caused the patch to become unresponsive or laggy when very dense sequences were played back.

    - the 4x4 matrix buttons are mapped but only working the 2nd and 3rd rows (the 1st one is setted to the default v2 script actions)

    This is strange...I can't reproduce, and I've not heard anyone else complain about this.  Are you using the correct steppr file?  (m4m7/patchers/monomodular_b996/drumsteppr/drumsteppr.amxd)


  • Can we please get an update for LIVE 9.7 as the same settings which made 9.6.2 function do not work with 9.7

  • They'll be an update available later today when I get home to double-check with controllers ;)


    a

  • Files are in the usual place, see earlier posts in this thread if you're unclear on what's going on (as well as the readme.txt file in GitHub repository):



    Please let me know if you find problems specific to 9.7 with details and ways to reproduce, I'll try to fix 'em right up!

    a


  • Buen dia Hola! quisiera saber si hay Alguna Actualización de secuencia de comandos para el CNTRL R en Ableton Live 9.7.
    Muchas gracias! 
    Saludos! 

  • Hi, I see the files in the "usual place", i.e. https://github.com/aumhaa/m4m7, but there are a great many directories and subdirectories underneath that.


    Can someone please explain exactly what files need to be installed (relative to the root folder at https://github.com/aumhaa/m4m7), and where they need to go, to get a Livid DS1 working on Live 9.7 for OSX?

    I'd just about commission this, simply for an installer!

    Thanks,

    Hotjacket
  • There are detailed instructions about which files go where inside the readme file in the GitHub repository.  


    This is from the readme:

    1) You MUST be using the most current version of Live! (as of this writing, version 9.7). You should also install the latest version of Max (7.3).

    2) Download this repository, preferably with a github client as I’m making frequent changes and it will be easier to update for you if you find bugs that I can quickly fix. Put the “m4m7” or “m4m7-master” folder inside Max’s packages folder, which can either be in ~/Documents/Max/packages or /Applications/Max/packages (either path will work).

    3) Copy all the folders from m4m7/Python Scripts to Live’s MIDI Remote Scripts folder.

    4) If you are using a Livid controller, you'll also want to copy all the folders from m4m7/Livid Python Scripts to Live's MIDI Remote Scripts folder.

    Hope this helps!

    a


  • Just can't seem to get the scripts to work for my base 2 with 9.7? Any ideas? 

  • Thx for update! 

    Got my Base working with 9.7 and the Livid_Base_v2 script. Two questions though:
    1 - Where shall I put the m4m7-folder? "Put the “m4m7” or “m4m7-master” folder inside Max’s packages folder, which can either be in ~/Documents/Max/packages or /Applications/Max/packages (either path will work)." - I´m on Max 7.3 and i can´t find any "packages" folder? Mine looks like /Applications/Max/Contents/... Shall I put it in the "Contents" folder? 

    2 - Will the Base-controller be discontinued from now on or is there a new Base script coming? Regarding v2 you write: "There is no guarantee when (or if) I will update these scripts again" Que???
  • edited December 2016

    The "~" character is shorthand for your user folder.  So in this case it would be something like:

    your_user_name/Documents/Max/Packages/

    I am not working on any new Base scripts currently.  I'm always available for commissioned work though.  I don't expect the current Base script to stop working with Live 9, and I suspect it will continue to work in Live 10 but I can't know that for sure until it is released.

    a

  • Amounra, so which syntsteppr should we use from repository? There are 3 of them now in the folder: 

    1)synthsteppr, 
    2) synthsteppr new, 
    3)  synthsteppr frozen, as far as I understand synthsteppr frozen for your own reference..?
  • SynthSteppr_new is the one you want, and I will update the repository to remove the two other ones.  

    If you download a new copy of m4m7, it should only have one file in that folder now (I've renamed the correct file as "SynthSteppr").

    Thanks for pointing that out, sorry about the confusion!  



    a

  • Base with Live 9.7 is not working for me. Some people are claiming that its working for them in this thread. What am I doing wrong? 

  • I have the base 1 and it's not working for me on windows 10 with live 9.7 and max 7.3. I've been trying multiple times to install. Is there anyone with this setup able to get it working?  
  • I don't have a way to check on Windows 10 at the moment, but its working on every other platform that I know of and the Python scripts are generally OS agnostic.  If you can PM me with a link to a copy of your log.txt file I can have a look and try to provide some insight.



    Cheers :)

    a
  • @amounra 

    ah thanks I checked the log file and saw the errors. now i fixed it, I hadn't copied all the scripts over from the python scripts folder ;)

    many thanks!
  • Glad to hear it!  Cheers :)


    a

  • I'm having trouble getting Ableton 9.7 to recognize my Alias8 as a multitrack controller. 


    Any help would be appreciated! Thanks in advance. 
  • I'm having trouble with my CTRL:R i installed the script and inside Ableton Live 9.7.1 i can't find it on midi to set up the script, please someone help me!

  • Please, before asking for help in this thread, be so kind as to actually read the entire thread.  There are explicit instructions both in this forum thread as well as in the m4m7 repository about what to do to get things working.  


    If you don't have success and want some help, I'm happy to oblige, but the first thing I'll need from you is a copy of your log.txt file.  Here's some information about where to find it:


    Also, please include some information about what you have done already to try to install.  "It doesn't work..." doesn't really give anyone much of a chance to help you ;)

    90% of problems I've helped people with come down to a single common problem:  not using a current version of the scripts.  Please make sure you're downloading the most current build from the m4m7 repository:


    a


  • Hi amounra, guys,

    Where can I find scripts for CONTROLR and Ableton 9.7 (I wish scripts for 9.7.1 would exist) if this "https://github.com/aumhaa/m4m7/tree/master/Livid Python Scripts" link is only for Ableton 9.6.2 and, I believe, previous versions?
Sign In or Register to comment.