Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Twitter

New MIDI Remote Scripts for Ableton Live 9.76

Hey guys, 

I've updated the Livid github repository with fixes for the most recent Live update.  You can pull them from here:

I highly recommend that you TURN OFF AUTOUPDATE in Live's preferences, I can't always guarantee that I'll be able to update these scripts in a timely manner in the future, and as a rule updates to Live are going to break script functionality.

If you find any issues, please let me know in this thread.  I've only tested the scripts to compile and load, but there could be some broken functionality that escaped my notice.





  • Hey Amounra,

    It's been a long time. I actually tried the new remote script, but on the CNTRLR V2 the sends are not correct, for some reason the first column on the right side is controlling the A sends and the second column the B sends. Let me know if something has changed in the script, and also can you send me the details to swap the sends to the right side again?

    Thanks in advance and look forward to your response buddy.

    Take care,

    Mike Bosch
  • Hi Amounra,

    This has not worked for me unfortunately. The DS1 is still now showing in Ableton 9's Preferences.

    I have downloaded the file from the following link by pressing "Save As"

    I have then copied the file to the MIDI Remote Scripts File (Ableton Live 9 > Contents > App-Resources > MIDI Remote Scripts), replacing the original.

    The Livid DS1 is not showing as a Control Surface as per the above.

    Please let me know if I have done something wrong.

  • Hi all,

    @ Simon: if you copy all the scripts from the github folder to the midi scripts folder in Ableton, the DS1 script shows up
    @Amounra: I have 1 midi track and 4 sends in my project template. If I open it up, the sends are now occupying tracks 2-5 on my DS1 until I add more audio or midi tracks. I'm not 100% sure, but I guess they were hidden before, which makes more sense in my opinion.

  • Hi Joe

    Yes have tried that.
    Have double and treble checked just to be sure but its still not showing as a Control Surface.
    Have tried restarting.
    I am using Mac 10.9.5 and Ableton 9.6.2
  • Sounds like there is something up with the sends.  I've been away from home for the past couple of weeks (no internet really), I'll try to have a look at this tomorrow or Wednesday.  Thanks for the feedback :)


  • Hi,

    I've got the same problem as Simondunne.
    I tried every combination I could to make live recognize it no way.
    Right now I have the 3 files from the Hub in C:\ProgramData\Ableton\Live 9 Suite\Resources\MIDI Remote Scripts\Livid_DS1_v2 and nothing appears.

    Thks for support !

  • Hi guys,

    Please make sure that you copy all the files from the master folder to your midi remote scripts folder, because it needs the mono framework file as well. So best is to copy all the files.

    Hope it helps you.

  • edited July 2016

    You also need the aumhaa folder for the newer scripts....

    I'm trying to take a look at the sends issue right now.


    edit::  I only have Base with me atm, and sends are working fine on it.  I'll check CNTRLR tonight when I have access to the hardware.  I assumed the problem would be across all controllers, since I didn't make any changes to them in that regard, but this one, at least, is working as expected.

  • Hi, I confirm that there is some issue with sends on CNTRL:R v2 script after this update. Also I still cannot launch scenes with this script after 9.6 update.

  • edited July 2016

    I've updated the repository for the CNTRLR_v2 and aumhaa files which should fix both the sends and scene launch problems.  Let me know if you find anything else please :)


  • Hey guys,

    So I have the same problem that Simondunne and olgarythm had. I own a Livid Ohm RGB and I've tried copying all the files from the folder to the Ableton midi remote scripts with no luck. None of the Livid devices will pop up in the control surfaces drop down menu. I am working with Ableton Live Standard 9.6.2 and OS X El Capitan 10.11.5. Please let me know if there is something that I am not doing correctly or if there are any further suggestions.


  • @Amounra, Hi!

    Thanks for this fix, its working properly now, sends and scene launch :)
    One more issue I can see now, I have one synthsteppr at my project and when I'm scrolling to the track with synthsteppr CNTRL:R is getting stuck and I have to restart it, once I deleted the track with synthsteprr from the project it works fine. I now that you are not supporting functionality of MFL devices anymore but it would be great if its possible to fix this issue that we can still use at least synthsteppr, as TB303 workflow is really unique in this device and I really want to continue work with it in my projects.
    Thanks in advance for you support. 
  • Hi Amounra,

    the fix that worked for the  CNTRL:R  didn't work for the DS1.

  • Hi Amounra,

    Yes I have copied all items from the folder and the DS1 does not show up in Ableton.
    It appears from the above that a number of people are having this problem so I assume its not an error in my process.
  • re: CNTRLR mods.  

     I'll have a look tonight.

    re: DS1 (and others):  Scripts not compiling.

    I just downloaded a fresh copy of Ableton 9.6.2, installed it, started it, pulled the Livid git repository, copied every folder from LiveRemoteScripts to MIDI Remote Scripts, and restarted Live.  All the scripts show up and load in Ableton's MIDI preferences.

    Maybe try the same?  There is a good probability that you're putting the script files in the wrong place.  Do you have more than one copy of Live installed? (that's a common cause for confusion)

  • The instructions read kind of weird. They imply putting the entire folder into the MIDI Scripts folder, when you should really put the contents of that folder into the MIDI Scripts folder. 

    But the Steprr is AFU. Crashes Ableton. I am unsure if I am supposed to take extra steps to place some of the files from github into a java directory I am unaware of, or if I am reading too much into it. 

    Kind of wish I could roll back Ableton at this point. Head, meet wall.
  • There are current versions of the stepprs in the m4m7 repository (in the patchers folder):

    I have not tested with 9.6.2 yet, but everything was working last time I checked and I believe other's have things working also.

    Instructions about where to place the files are available in the readme.txt, although generally all you need to do is place the entire m4m7 folder inside Max's packages folder and restart Live/Max for everything to work.
  • > Spaker said: > The instructions read kind of weird. They imply putting the entire folder into the MIDI Scripts folder, when you should really put the contents of that folder into the MIDI Scripts folder. 

    Indeed, this is confusing

  • edited July 2016

    re: Instructions.

    Are you referring to the instructions in the readme.txt inside the repo?  I didn't write them but I'll try to make things more clear....

    re: CNTRLR.

    Abes made a really destructive, goofy change to one of their base-classes in 7.6.2.  It's likely to cause all sorts of havoc for a while until I find every line of code that its impacting.  In the meantime, please continue to report problems here.

    re:  STEPPRS.

    If you want to continue to use these, I recommend staying with the version you are using.  I will NOT continue to maintain these going forward.

    However, I will do my best to get them working properly with the current release of m4m7 (mostly working at the moment, shoring up a few problems here and there so stay tuned).  You'll need to install the mod package yourself, and I'm not going to maintain frozen versions of these sorry.  There is a frozen version included for each at:


    However, those probably will not work with the current Python scripts.  Let me know if someone get's them working and I'll tag them with comments.  You'll probably have to backdate the repo in order to find Python scripts that are compatible with those, probably around February of this year.


  • Re: Stepprs.

    They are not working with the current Python script, Ableton crashes every time when I use them. Do you mean, that I have to use Python scripts from February and Ableton from the same time accordingly to make them work?

    Re: CNTRL:R Script.
    One more problem, similar to problem with sends but with macros: first 3 macros of the rack which is automapping to the right side knobs currently is mapping horizontally..

  • Hi Amoura

    Still no luck! I will detail exact steps as I may be doing something obviously wrong:

    - Downloaded and reinstalled new version of Live 9.6.2, 64-bit, replacing original
    - Downloaded ALL 3 files from the following github link
    File names: "", "" and ""
    - Download method: For each file presented right clicked and chose "Save Link As..", saving each to a Folder on my Desktop
    - When Live Installed, accessed MIDI Scripts Folder by Ctrl Clicking the Application, then Contents > App Resources > MIDI Remote Scripts > Livid_DS1_v2
    - Replaced the three files in folder Livid_DS1_v2 with those on the desktop. Namely, "", "" and "" as above
    - Opened Live and MIDI Controller is not showing

    I hope there is something simple I am doing wrong in the above and maybe others with the same issue as me are doing the same.


    Note: there is only one version of Live installed on my computer

    Note 2: when I open the script there is some text within the file that may be causing some confusion. Namely:

    "Skip to content

    Personal Open source Business Explore

    Sign up Sign in

    Pricing Blog Support Search GitHub

    This repository


    Code Issues 0 Pull requests 1 Pulse Graphs


    Branch: master

    Switch branches/tags

    • Branches
    • Tags

    beta master

    Nothing to show

    Nothing to show

    Find file Copy path


    Fetching contributors…

     Cannot retrieve contributors at this time

    Raw Blame History

    289 lines (207 sloc) 15 KB"

  • Hi Amoura

    As an alternative to the above, I don't mind MIDI mapping the controller myself. I can do this fairly quickly.
    The only additional help I would need is how to create a "mode cycle button"
    In the standard script there is a button which allows you to cycle between (Mute/Solo, Record Arm/Track Select, Clip Grid/Stop All Clips)
    How do I create such a button in the Editor.
    I realise this is not related directly to this thread but it would be an alternative to solving the above.
  • edited July 2016

    Hi Amoura, are the remote scripts updated from the livid instruments website and wiki, or are the most recent stable versions still first and only on github? Also, the github readme refers to a .js file that needs to be retained, however I couldn't find any mention of it in the zip. Is it really necessary to do anything but drop the folders into the Remote Scripts of the application bundle?

    Also, I noticed that the Remote Scripts wiki has not been updated since Feb. Are there any changes or are there only fixes? Are there instructions that need revising for v2 of the scripts, or a revision history section included in the wiki?
  • edited July 2016

    Hi everyone, 

    i'm having a hard time working with this new script on my ohmrgb. 
    Unlike other versions, whenever i scroll or change "page" for the drumkit section, I hear glitches and spikes in the audio. 
    I'ts really annoying and i will have to go back to a more stable script version. 
    The last working script was doing great on the 9,1,4 ableton version.

    I'll keep an eye on this thread, hope you guys can sort this out.

  • OK, so here's the deal.

    Because of the amount of confusion (for both you and me), I've restructured things a bit.  I will not be updating the LividRemoteScripts repository on a regular basis any longer, as it's too difficult and confusing for me to keep two different versions of the same scripts up to date.  Instead, I've put the newest v2 scripts in the m4m7 repository where you can download the entire "mod" package for use with Max7, as well as all the relevant Python Scripts that are supported.

    Here's the repository link:

    I will probably not be developing the v2 Livid scripts further (beyond commissioned work and the controllers I use personally), but I MAY continue to update them for Live compatibility.  Or I may not.  It just depends on how bad Ableton updates break them, and how much spare time I have in the future when that happens.  What I'm saying here is that if you like the way you're rig is working now, you should TURN OFF AUTOUPDATE in Live.  Also, its not a bad idea to back up all your Python files and put them somewhere safe, and put a note on them so you know what version of Live/Max they work correctly with.

    I will commit a final version of the v2 scripts that are compatible with Live 9.6.2 after the dust has settled and I've heard back from users that everything is working as it should.  

    For those of you using the stepprs, you'll find them in the Patchers/monomodular_b996/ folder.  Don't use the frozen ones, they only work with the older scripts.  I've only left them there for my own reference.

    There are instructions about where to put the files in the readme file inside m4m7.  If you download the repository and follow the instructions in the readme you should have success.  If I left something out or something is unclear in the readme, please let me know and I'll do my best to improve it.  Documentation is certainly not my best talent ;)

    I have made several changes to all the v2 scripts, hopefully I caught most of the big problems.  There are still a few small issues that I've yet to sort out (mostly issues that go away after switching devices the first time).  I'll do some further work on this as time permits.

    Good luck, and cheers!


  • Should be fixed now.


    You need to place all of the folders from the repository inside the MIDI Remote Scripts folder, not just the one you want to use.

    Hi Amoura, are the remote scripts updated from the livid instruments website and wiki, or are the most recent stable versions still first and only on github? 

    On Github.  For now on.

    Also, the github readme refers to a .js file that needs to be retained, however I couldn't find any mention of it in the zip. 

    Don't worry about it.  If you follow the instructions in the m4m7 readme (link above) then you shouldn't have to worry about copying anything but the Python Scripts and Livid Python Scripts.

    Is it really necessary to do anything but drop the folders into the Remote Scripts of the application bundle?

    And restart Live.

    Also, I noticed that the Remote Scripts wiki has not been updated since Feb. Are there any changes or are there only fixes? 

    Only fixes, as far as I can recall.  Any changes are unintentional and are happening because of changes Ableton made in their API/Framework.

    Are there instructions that need revising for v2 of the scripts, or a revision history section included in the wiki?

    As above.  Changes can be seen in the repositories history.

    You might want to check out the most recent changes.  I haven't had any of the issues you're referring to, but there were a few fixes I had to apply to the OhmModes script so perhaps they will clear things up for you.  If not, I'm happy to look at reproducible problems if you can give me steps to make them happen.

  • THANKS @amounra!!

    Scripts are working in 9.6.2 and the 9.7 beta as well just FYI. A few months back you posted a tweak to the DS1 scripts to allow for all encoders on the 8 channels to be mapped to the Sends by default. Just checking to see if you think that tweak will still work with this updated version. I'm going to try it tonite. Thanks again!!

  • Hi Amoura

    Ok steps 1 to 4 of the Read Me followed and the DS1 now shows as a Control Surface - thanks!
    Only thing I did not do is put the master folder "m4m7-master" in the Max Packages folder as I could not locate one. Not sure if this is an issue. (I'm not very competent at this level so can only take things at face value and the specific folder "Max > Packages" does not exist as far as I can see).
    Thanks for your help
  • OK the SEND tweak to the DS-1 script still works in both 9.6.2 and 9.7 Beta. If anyone is interested... If you're using the most current Livid_DS1_v2 script:

    Open the main script file in a text editor, go to line 217:
    self._strip[index].layer = Layer(priority = 4, parameter_controls = self._dial_matrix.submatrix[index:index+1, :])

    Change that to:

    self._strip[index].layer = Layer(priority = 4, send_controls = self._dial_matrix.submatrix[index:index+1, :])

    Save the file in place, restart Live, and you should be able to control the sends for the selected track with the knobs on your DS1.
  • Amoura- this is mighty brilliant and kind of you to have shared. Thank you for taking a moment to clarify! Put your answers in the github files/comments/revisions so you don't spend a lifetime looping back here! I feel for you. (Or can I do that?)

    No good deed goes unpunished which is why I thought of yet another question for you!:

    What are the base_le and base_m4l folders doing? They weren't in there before, I'm just wondering if they offer different functionality, extra support, and if I'm obligating an additional native midi slot to use them? Is the LE version a more "lean"/basic version of the script? (At this point I wish I could just use the pad scales. Don't even like the device control, much less the sequencers nor clip navigating without a "reset" shortcut, visual feedback ETC)

    Cheers to you!

Sign In or Register to comment.