Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Twitter

Unable to get Guitar Wing to work with Guitar Rig 5

To anyone who can assist me, thank you in advance.

I recently purchased the Guitar Wing and am unable to get the controller to work in Guitar Rig 5.

What is strange is that the Guitar Wing controller buttons work with the stand alone WingFX plugin but that’s it.

I've downloaded/installed/configured the following Livid software:

• gwing editor 1.04
• gwing firmware update dater 1.05 with v1.18 bin
• Livid WingFX Installer
• Welcome to Guitar Wing
• NI Guitar Rig Content

I followed the instructions for configuring Guitar Rig 5 by importing the preset  “Livid Guitar Wing by (!).ngrr”.
The imported setting show up as shown in the Livid installation video, however the Guitar Wing buttons do absolutely nothing.
Am I missing something?




Comments

  • I've now been able to Guitar Rig 5 to work by launching the stand-alone Guitar WingFX plugin first. Is that how it's suppose to work?  Because nowhere does it say so and I would think it shouldn't have to be launched first.

    Also with or without the WingFX plugin launched first Guitar Rig 5 shows under File - Audio/Midi settings and the MIDI Tab that the Guitar Wing is off, yet will still work when launching the stand-alone Guitar WingFX plugin first.





  • I am also experiencing the same problem.
    Guitar Rig5 will not let me turn "On" the Guitar Wing as the MIDI input.
    I tired loading the default setting etc. and leaving WingFX on...

    I have a Windows7 PC.
    I also have trouble running the 64 bit version of the Wing FX (32bit works fine).
    I am ok with using the 32 bit version.

    Regards,
    Ruben

  • OK I got it to work. The problem was with me :)
    In Guitar Rig under the MIDI input settings I was clicking on the "Livid Guitar Wing"
    portion and did not get a sub menu. You HAVE to press the OFF button (to the right side)
    to get the option to turn it on duhhhh.......


    Regards,
    Ruben

  • that'll do it! Have fun.

Sign In or Register to comment.