Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Twitter

CNTRL:R script V2 for ableton 9.6 device selector issue

Hi,

Device selector doesn't work in Ableton 9.6 (In updated version of script for 9.6 version).
 

Tagged:

Comments

  • Thanks for the report :)  I can't confirm though....it's working fine for me here.  I even fixed the assignment button in the most current version (which I think has been broken for a while).  I've updated a few things (last update was on the 23rd I think)...have you tried the most current version from GitHub?  If not, any further details you could give me would be great.


    a

  • Hi amounra,

    Yesterday I also discovered issue with assignment button and some freezing was happening. Script which is currently in official integration guides for ableton 9.6 is definitely has some bugs and is quiete old, can you update installer please?
    I tried to put whole Remote script folder  Livid_CNTRLR_v2 then, files from remote script folder and replaced the old one, try restarting my computer, result is the same for me, script for CNTRL:R disappears from the list of available midi devices. So I reverted back with an old installer and CNTRL:R appeared again with issues. Please update installer.

  • Ok, I moved amounha folder to remote scripts and it seemed working now, however I think its a good idea to update installer.

    Thanks.
  • Ok currently I have another issue after update:

    Currently device selector and the track selector is moving red area without SHIFT button pressed. So it means it behave by default as I would press shift and control selector knobs. why its like that?

  • We'll update the installer once I have some reports of successful deployment in the outside world.  So far this is still beta until I can get confirmation from a few users that things are working.


    Re: moving session ring.   I'm not sure I understand what you mean here.  The top two right encoders should ALWAYS move the session box.   When shift is held, they move it in page increments, whereas without shift they move it a track/scene at a time.  Are you experiencing something different?

    a

  • What I'm trying to say that in my case they move in page increments all the time, I cannot move it as track/scene at a time.

  •  I understand now.  I'm not experiencing that, though.....is it always the case?  If you start a song from scratch does this happen?  Have you tinkered with the Map.py file at all?



    a

  • No, I didn't. Just now: I  replacex midi remote scripts in ableton folder from ableton installer, run installer of the Livid remote scripts for ableton 9.6, replaced files in folder CNTRL:R with files from Livid_CNTRLR_v2

    It is still the same I cannot move it as track/scene at a time.
  • edited February 2016

    Ok that's a strange one.  I'll look into it more tomorrow when I have some time...I can't imagine what would cause that, though.  


    For the record, all you need to do to install is put the aumhaa and Livid_CNTRLR_v2 folders from the repository inside your MIDI Remote Scripts folder and restart Live.  Livid_CNTRLR_v2 will show up as a control surface in preferences.

    a

    edit::  I think that might be the problem.  Try installing fresh again, but this time don't use the Installer.  Thanks for testing :)
  • Hi Amounra,

    I tried clean installation of ableton, I didn't use installer and just moved CNTRL:R v2 script folder, and amounha folder. CNTRL:R v2 doesn't show up in ableton.... maybe this is something to do with ableton ".pyc" files. Which Ableton is adding to .py files, and as I can see all other script folders have only .pyc files. I don't know. 
  • No, that's all it should take.  The pyc's are the compiled py files, they get created when Live first starts.  So, normal there.


    Are you sure you're using Live 9.6?  This won't work with earlier versions, nor with the current beta (there are about to a few small changes released with Live that will break the 9.6 scripts, which is why I haven't released an installer yet....I was hoping that an official Ableton release would happen this week and I could package it all up for that).

    If you send me your log.txt, I can probably see pretty easily what the problem is.

    a

  • How I can extract logs for you?

  • Hi Amounra,

    As we discussed, I still have issue with increments.
Sign In or Register to comment.