Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Twitter

OHM RGB and Bitwig - Group and Scenes launch

Hi, 


I just bought Bitwig Studio and I'd like to use my Ohm RGB with it. 
-Unlike Ableton Live-, for the moment, I can't Launch a whole scene by the 8x8 grid, and when I make a group I can't launch the whole group. 

Does anyone know how to fix/do this ?

Thank !
Technolife

Comments

  • Groups didn't exist in Bitwig when the scripts were written.  We're looking into a way to implement functionality for groups in our scripts.


    a

  • Hi !


    Awesome ! Thank a lot :D
  • Hi, 


    Do you know when the script will be available ?

    Thank.
  • Sorry, I don't.  It will be soon.

  • Thank, I can't wait to use my Ohm RGB with Bitwig :D



  • I have recently updated the Bitwig scripts to implement some fixes for bugs introduced in the most current versions, but unfortunately there still doesn't appear to be access to group launching via the API.  I've tried contacting Bigwig about this (and some other issues I found with current versions of their API) but haven't heard back from them so I really can't give any sort of ETA yet, sorry :(

  • Hi, Amounra, 

    Thank for the reply. 
    Is it the last repository with bug fix ? 
    Did you get a response from bitwig about updating the API for group launch ?
    Hope they will do it soon. 
    Thank again, 
    Cyril
  • I was just thinking, when we create and fold a group in Bitwig, it makes it as a scene in the mixer view. 

    So we have master scene, group scene and clip. 
    In this script we can see that it's launching a whole scene (line 339) : SceneBank/LaunchScene

    So, maybe we could launch clips from a group by its own scene launcher ?

    Cyril
  • Just saw this, haven't been in much lately.  I see what you're talking about, however I'm not sure if it does what I think it does.  I'll drag out the Launchpad as soon as I can and see if I can get something useful from that script.  Thanks for pointing this out, I still haven't heard a peep from BW about any of the issues they've introduced that affect our scripts.

  • Hi, 

    I've tested with the new script from my Nektar Panorama P6. 
    I'm able to create a group scene and then I can launch it. 
    But It only launch the scene, not the sub-clips.
    I've made a Google Drive with some videos if you want to see : 
    There is maybe something to do with it, using some other reference of the API scripting. 
    We can launch a group when we map it with to key. So why we could not launch it with a grid-based controller ?

    I've also emailed Bitwig, hope they will have a look soon. 
    However, do you know a possible workaround for launching them ?
    Like I could map them to my Ohm RGB, but I will only have 8 scenes, because of the number of the pads. Something like when we scroll down the grid, the note on the pad change, so I could manually map all my groups on notes... ?

    Sorry for being impatient, but I really need it as soon as possible. 
  • AFAICT, the only hook available in the API is to fire the entire scene, not a group's scene contents.  If there is a method available in the the API, BW haven't documented it (or I'm missing it somehow).  Either way, I'll have a look at what you referenced and see if I can do something with it later today.


    As far as Scene Launch is concerned, you can already do this by holding down the selected track's select button (top row) and pressing one of the far right grid buttons.

    I just bugged BW again about this again, and downloaded the most current release to see if there are any changes. For some reason, I don't receive emails about new releases anymore so I didn't know about 1.35 until I opened up BW just now.

    a
  • Yup, someone from Bitwig User Group got it Working, here is the repo : 

    And " https://github.com/.../blob/master/daw/CursorDeviceProxy.js is the place where the real work of groups and device layers are."


    Hope it could be a solution. 
    If it's to hard or whatever, don't waste your time, for the moment I'll take a keyboard and map each group to a key. 
    Cyril
  • Hi, 

    As a workaround I'm trying to use the switch bank (so I have 4*8 pad to manually map my clip). 
    But when I change the bank, it seems to change the midi channel and the script doesn't work anymore. 
    How can I put it in Omni mod ?

    Thank, 
    Cyril
  • edited January 2016

    There are some Group features coming with 1.37 that will resolve some of these issues with groups.

  • Hi, 

    Thank Amounra, that's a good new !
    Hope it will be released soon. 

    Cyril
  • Hey, 


    Just found the 1.3.8 version of Bitwig, awesome, we can now group launch !

    Is there a way to have the OhmRbg following the folded/unfolded mode of the group track like in ableton ?
    Because for the moment, even if the group is folded, the ohm show every tracks. 
    And could you add a light feedback of the group track ?

    Thanks !
    Technolife
  • I was promised a method to do this in the 1.37 beta, but when I downloaded it didn't work correctly.....I didn't realize 138 was out, but I will check it out and fix if possible as soon as I get finished working on my current project.


    a

  • Hi, 


    Thank, Amounra, 
    Is it possible to fix bugs like wrong selected track when the controller is plugged ?

    Thank,
    Technolife
  • Can you please describe the problem in a little more detail?  I'm not familiar with the problem.


    a

  • Hi Amounra, 

    After a little break up I'm back to you. The bug is when I have ohmRgb plugged in and a group, I can select the group, it always come back to a child in the group. Here is a video : 

    There is also a little bug when selecting clip, it doesn't select the right one some times. 

    Thank you, 
    Have a nice day :-)

    Technolife. 











Sign In or Register to comment.