Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Twitter

Cntrlr shows up under I/O but not Control Surfaces

Cntrlr shows up under I/O but not Control Surfaces

Ableton is finding the python scripts and compiling them, but they never show up in the Control Surfaces list.


Cntrlr with latest firmware

Ableton Beta 9.5.1 b2 on Windows 10

Thanks!


Tagged:
«1

Comments

  • Hi Adamm,


    I don't think the script for the 9.5.1 beta is ready yet. As far as I know Ableton has changed everything in 9.5.1 again and the current script will most likely not work with the beta version.

    Amounra might be working on it, or maybe has one ready, but until he has the script for 9.5.1 ready, it will not work.

    Just hold on till the final release of 9.5.1 and they'll roll out the new script.


    Mike
  • Sounds good! Thanks Mike.

  • Did you get this figured out?  It should be working if you're using the most current build....


    a

  • Using the latest download from the website in the latest beta of Live, no go, still.

  • How are you installing it, are you using our installer?  If you have more than one copy of Live in your applications, it will only install to the first one it finds.  Try moving any copies of the Live application that are present into a subfolder in your Applications folder and try the installer again.  AFAIK there is no problem with the current version and 9.5.

  • Ableton is seeing the Cntrlr, the Input and Output ports show up but none of the scripts appear in the dropdown. When I push a button, Ableton indicates that it's receiving MIDI data.
    I'm using your installer from the page http://wiki.lividinstruments.com/wiki/CNTRLR_Ableton_Live_Remote_Script_v2
    The installation is into C:\ProgramData\Ableton\Live 9.5 Beta\Resources\MIDI Remote Scripts
    I checked, the files are there and I see .pyc files that were generated on the first run.
    Looked in log.txt and found the following:  (see http://pastebin.com/2LvbxEkD - too large to fit in message) excerpt follows:
    (snip)
    4283 ms. RemoteScriptError: Traceback (most recent call last):

    4286 ms. RemoteScriptError:   File "<string>", line 1, in <module>

    4289 ms. RemoteScriptError:   File "MIDI Remote Scripts\Codec__init__.py", line 3, in <module>

    4292 ms. RemoteScriptError:    
    4294 ms. RemoteScriptError: from Codec import Codec

    4297 ms. RemoteScriptError:   File "MIDI Remote Scripts\Codec\Codec.py", line 38, in <module>

    4300 ms. RemoteScriptError:    
    4303 ms. RemoteScriptError: from _Mono_Framework.DeviceSelectorComponent import NewDeviceSelectorComponent as DeviceSelectorComponent

    4306 ms. RemoteScriptError:   File "MIDI Remote Scripts_Mono_Framework\DeviceSelectorComponent.py", line 10, in <module>

    4309 ms. RemoteScriptError:    
    4312 ms. RemoteScriptError: from _Mono_Framework.MonoButtonElement import MonoButtonElement

    4315 ms. RemoteScriptError:   File "MIDI Remote Scripts_Mono_Framework\MonoButtonElement.py", line 7, in <module>
    (snip)



  • Along the way I had also trying uninstalling and reinstalling, removing the Remote Scripts folders in between installs.
    Currently I am on 9.5.1b6


  • Tried the files from Github and interestingly some of them show up, such as

    Livid Alias8 M4L
    Livid Base M4l
    Livid Block

    and a few others,  but not Cntrlr, still the same errors in the log file.


  • Completely uninstalled and reinstalled Beta again - same result as above.

    Did a fresh install of 9.5 and I do see the scripts there.

  • So sorry, I missed that part where you mentioned you were using the beta.  Scripts definitely won't work with beta yet, they've changed a lot of things (yet again) and I'm in the process of updating.  Sorry for the trouble.  


    Last version current scripts will work with is 9.5 release. 
  • Hey Amounra,


    Hope you are doing fine buddy. Now that Live 9.6 is out, have you got any update about the new script for Live 9.6?

    Looking forward to it.

    Mike
  • Likewise, Mike!  We'll have something out very very soon.....there are already working versions of our scripts in our github repository.


    a

  • Hey Amounra,


    Nice to hear that, are the working versins the prelim built?

    I think I got them already setup, but unfortunately my CNTRL:R is now packed up already, because I am going to move my business and studio to Mallorca, Spain on the 24th of February.

    I'll check out the script as soon as I can and maybe I get a real urge and unpack it for a short session hahahahaha.

    Speak soon buddy,

    Mike
  • Yes, the scripts in our github repository are working with the Live 9.6 release (AFAIK....if you find something that doesn't work, please let me know).  We'll have new installers up very soon.


    a

  • @ Amounra,


    As usual I will report any issues if I find any.

    Mike
  • Hi there, I'm new here in the forum.  I also work a lot with the CNTRL:R, also play live. I really really need that script for Live 9.6.. Also need the Drum-Stepper..
    Thanks in advance..
    Markus

  • Hi Aszent,


    Try these. I haven't had the chance to try it out myself yet, but this will probably sort you out until Livid got the installers ready.


    Mike
  • My bad,


    They already have the 9.6 installers on the website.

    Mike
  • edited February 2016

    Yes yes yes!!!!

    THANKS LIVID!!!! Great Job, great support  

    Thanks Mike!!!

  • There were still a lot of bugs I was finding, don't bother reporting them yet as I'm rewriting everything from (more or less) scratch.  


    a

  • Ok, looking forward to the updated script Amounra.

    It will probably be ready when I arrived in Mallorca, so I will be able to test it, since most of my gear is already shipped.

    Mike
  • Just tested it but sometimes it seems like the script is loosing itself on the CNTRLR..  

    I'm also wondering how I can reach the STEPP:R that I use a lot. Until I couldn't find out how to open the template that I can use it like in Script 1. In the manual I can't find a description for that.

    Is it possible to use Script 1 for Live 9.6? 

    Can somebody help me?

    Cheers..
    Markus 

  • I'll be pushing a new version of CNTRLRv2 to github tomorrow, it should fix some problems (although it's still a work in progress, I think it's about done now....I could use some bug reports if you find any).


    In the script you're using, you can tag a device with "@d:1", for instance, as the first part of its name.  So, say you want to get to the Steppr quickly, you'd rename it to:

    @d:1 MySteppr

    Pressing the top left encoder button brings up the device selection grid on the 4x4.  Any device that you've tagged starting with the "@d:" prefix will  be selectable directly from the 4x4 grid.  So if you've tagged your device as indicated above, you'll be able to select it by pressing the top left button on the 4x4.

    Make sense?  You can add a bunch of devices in this way....@d:2, @d:3, etc.  I think there is a "set" button in the bottom right corner that will allow you to toggle the tag on the currently selected device by holding it and pressing one of the matrix buttons (not sure if that is working in the script you're using though).

    Keep an eye on our github repository, I'll push the new CNTRLR script as soon as I get a few more things sorted on this end.

    a





  • There's a new version of CNTRLR  named CNTRLR_v2 in our github repo, make sure to move aumhaa folder into your MIDI Remote Scripts folder as well or it won't work.



    a

  • Thanks. Will try it this week.

  • edited February 2016

    Dear Amounra,
    just tested it.. ok.  Nice, but..
    I'm not using the Script functions like navigating and all those other tools. I just need the controller setup like in the pre-version for ableton 9.5., a naked CNTRLR and the Stepp:r (my TR-909)..  that I can reach by toggling the first push encoder.
    How I can get these settings?

    In your description above you told me to add a ..@d:2.. to the stepper. Sure, I can select the stepper, but it doesn't work like before to select the 16 sounds and also to select a step in the TR-like sequencer. Also the 12 encoders are not corresponding to the Stepper's edit-knobs.

    Thank you.
    Markus

  • Perhaps  you're also still using the OLD stepprs?  You'll need to update them to the current ones or they won't work with the new script.  There's no way I can continue to support the old-style scripts (and stepprs).  I did my best to provide a way (with the device selector) to still be able to get directly to the steppr you need to access, but there's usually a price for progress :/

  • Well I think you're right. Seems like I'm really using the old ones.. Sorry.

  • No worries :)   You shouldn't have to fuss with it much, but let me know if anything causes problems with your old presets.


    a

  • Now I'm into it..  Some things sometimes need some time :-)

    One question about the Stepper and also the Accent:  Normally when Steppr was started the 16 pads of the CNTRLR were showing the sounds that are playing. But now there's no reaction..

    Any idea? 

Sign In or Register to comment.