Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Twitter

New CNTRL:R Live script

edited November 2014 in Hardware
There's a new Live script for CNTRL:R, info here:

http://wiki.lividinstruments.com/wiki/CNTRLR_Ableton_Live_Remote_Script_v2

I hope to knock out a rough video next week, because it's really quite different. It puts sequencing front and center, plus the Stepprs are integrated in a really nice way. It's incredible, really.

«13

Comments

  • Hi, I just unboxed my CNTRL:R and downloaded the Script V2, will try it for the first time, I have Live 9.1.1 though, I saw it on Wiki that it's required like 9.1.5 and up so my question is, if I install V2 will it not work at all or will it just not work it fully (i.e. will it work like V1 perhaps..) I'm wonderign if I should just stick to V1 for now before installing anything at alll... 

    Thanks
  • Hi Tartari,


    It will not work at all with the earlier versions of Live. It is best to upgrade to the latest Ableton version to use the V2 script. This is because the earlier versions of Ableton work with a different Framework.

    If you have more questions just post them here and anyone is happy to help.

    Mike Bosch
  • Ok.. thanks.. one last question.. sorry for the bothering... do I need to have Max for Live installed to run V2 once I update Live to 9.1.5?

  • You don't need Max for Live for the script to run, but if you want to use the Stepprs (drumsteppr, synthsteppr and accent) then you need Max for Live, because they are Max devices.


    The V2 script has a build-in sequencer so you could start sequencing straight out the box.

    Don't worry about asking questions, I'm happy to help you out.


    Mike
  • I_PI_P
    edited November 2014

    Hello Mike!!

    I update to the latest live 9.1.6 x64 on windows 8.1 and installed the new V2 script BUT

    now my controller wont recognized at all from live!

    I don't even have the red square around the clips :/

    and when I return back to v1 everything is back to normal... when back to V2 nothing

    Edit:

    at the wiki:

    ...and select "CNTRLR Control Surface" or "CNTRLR Control" as the input and output ports.

    to me is just the classic "Cntl r" on input/output ... no "CNTRLR Control Surface" no "CNTRLR Control"

    don't know if that matters at all. for now staying with v1 but im very very hot for v2


  • Unfortunately I am using a Macbook and not a Windows machine, but I will have  look at it on my windows laptop that I use for work and try it out. I'll let you know when I have tried this out.


    The only thing I can think of is that maybe the older scripts are mixing up the connection, so what you can try is to move the older remote scripts to another location so you have a back up in case this doesn't work. Then try to install the new V2 script and see if that works. If this doesn't work let us now and in the mean time I will install Ableton and the remote scripts on my Windows machine to see if it works and maybe I can see what the problem is.

    Mike
  • thanks Mike!

    I have try everything without any luck at all!

    even left contR v2 alone in the folder after a deep clean-up/reboot of the system! the same problem!

    v1 still flawless!


  • OK Give me a few minutes and I'll see how it works on my windows laptop.


    I will post my findings in about 30 minutes here.

    Mike
  • Hi I_P,


    I just saw that when installing the remote scripts V2, ti says Ableton 9.1.3 and greater, so there might be a problem with this, because 9.1.3 is using another Framework. I am just rebooting the Windows laptop and will get back to you with more details in a few minutes..

    Mike
  • Hi I_P,


    I don'w know what is going wrong at your setup, but I have installed ableton on my windows laptop, installed the V2 remote scripts and all is working perfectly, just as it works on my Macbook.

    I have selected the cntrl r as input and output with Livid CNTRLR 2 as Control surface, switched on the track and remote for the ins and outs and all works perfectly.

    Do you use more controllers with ableton? Also let me know if you use any third party applications or devices for midi input or output. And make sure it is Ableton 9.1.5 or greater.

    Don't worry we'll find out what the culprit is.
  • still nothing here!
    also after the many many tests (from firmware reupdates to system cleanups etc) i lost the lights off the encoders completely and couldnt get them back! even v1 stopped responding!
    had almost a hart-attack with the thought that my cntlr could be dead!
    thank god when i hook it on the macbook (live 9.1.5) everything worked perfect inc the v2 script!
    on my pc i have the latest 9.1.6.

    so it is me the problem (PC) and not the script!
    thanks very much for trying to help Mike, appreciated!

  • Can you please send me the log.txt from Ableton's preferences?  Here's some info on where to find it:



    I've pm'ed you my email address.  Thanks :)

    a

  • Hi I_P,


    Now you got the main man to talk to, Amounra, should be able to help you out and find what it is, since this problem is a bit deeper as I thought.

    Hope you get it sorted soon.

    Mike
  • Are there any sends in your Ableton project?  If not, can you try adding some sends (make sure there's at least 1) to your project before adding CNTRLR_2 as a control surface?  Please let me know what happens....


    a

  • Update!!

    everything works perfect after deleting live's pref. files and re-set the program from scratch!

    happy mode on!

    and v2 is so so so AMAZING!!

    thanks guys :-)

  • Glad you got it finally working, have fun with the script, it is indeed amazing.


    If you have any more questions just let us know.

    Mike
  • An overview video is at

    so you can see it in action. 
     The action moves fast so it's best used as a companion to the wiki page!

  • Thanks for the reply. I updated i to live 9.1.6 and installed it now. I'll be in Austin on December 2nd and would like to know if you guys have any kind of "crash training"  on site for the CNTRL:R.. or..in case you don't... is Livid instruments open for visitors?

    Thanks again.

    Victor
  • We don't have any formal training available, but yes I can give you a tour while your in town!

    Contact us through our support portal to set up a time:

    http://lividinstruments.com/helpdesk/

  • Thanks! Ticket # 970915 opened! Hopefully we can make it for Dec 2nd!

  • I plan on implementing a user mapping and using only that- as I understand the guide, I push the top right encoder to activate user mapping and go from there. Will I have to push that encoder every time I load up my template?

  • @milkthistle,


    Yes the top right encoder is to enter the user mapping and then you can use the bottom 8 encoders to select the user mapping pages, they represent channel 5 to 12. So pressing the top right encoder switches to the user mapping and pressing it again will return to the default remote script. If you have any more questions just let us know.
    I have also made a DJ template with some mapping for the encoder, you can find the free version on the forum if you would like to give it a try, and if you want the full version there is an intro pricing structure for the first 75 buyers. The free version works great as well if you just want the basic functions and the instructions might give you some guide lines and ideas for your own mapping.

    Keep It Spinnin'

    Mike Bosch
  • edited November 2014

    You can try changing the script, line 459:


    self._main_modes.selected_mode = 'Translations'

    That SHOULD kick it into UserMode when the script starts.  Can't guarantee it will work (on vacation right now and can't test it), but theoretically it SHOULD work.

    a

  • I'll have to experiment a little with @mikebosch 's template and the new official scripts to see what sticks for me. Thank you very much for mentioning this Mike, I'll respond in the corresponding threads as questions come up.

  • If you have any questions feel free to ask. Another template is coming soon with some advanced features to combine DJing with Live performance.

  • I think I'll just stick with a user mapping for the official MIDI remote script now- I looked through the python files and the LED lights seem more straightforward to set up than before.


    Is there a way I could set up the lights in a user mapping? An example would be, I'd like to set up one of the LED buttons to activate a macro in an effects rack when pressed, and blink purple while it's active.
  • I'm not sure if that can be done. I guess you need Amounra for this one. He knows more about how to do it, if it is possible. The thing is that the user mappings are using different channels in Ableton, and these are virtual channels, so I think you would need to do some python scripting in the remote script to get this done.


    I might be wrong, but as I said Amounra is the man for this.

    Mike
  • First of all thanks for the tour, it was very nice to meet the people over there. Now back to the learning curve...

    I noticed that both the Scene and Track selector encoders are ultra-sensitive meaning they skipping up to 4 scene/track until it reaches the next "resting" point of the encoders (instead of going one by one(. This has proven to be rather difficult when I need the encoder "to sit" on a drumrack so I can "actvate" the stepsequencer.
    Is there a a way I can reprogram these encoders; at least at track level... to move track by track along the "resting" marks on the encoders?

    Thanks

    Victor
  • I had exactly the same idea. I found that it is better to have the encoders move the red box track by track or scene by scene, instead of 4 tracks at a time. This way you could scroll through your set in an easier way and if you would want to move in  steps of 4 tracks/scenes, you could always use the shift option.


    Besides that I have encountered a problem in the drumsteppr. I clicked on the CNTRL:R to rules to set some rules, but when I go back to mutes and select another drumpad to change a parameter, I realised that the parameter names are not shown correctly and freeze to the drumpad that has been used to set rules.

    Could you look into this Amounra???

    Mike
  • Really loving the new script! There is a small problem though : the scene select and track select knobs move to high in value so whe you move the dial it bugs and goes way too far rather than to the next track.....

Sign In or Register to comment.