Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Twitter

(Solved) Error when mapping 2x16 CNTRLR buttons in other mods in Ableton

edited July 2014 in Hardware

Hi Guys,


It seems that there is a problem in the remote script when I try to map any of the 2x16 buttons in other mods in live. I tried factory reset in the editor and checked everything again, but the problem is still there.

Whenever I map a button in  another mod (and by the way this also applies to the 4x4 buttons), it seems that they have a momentary action instead of a toggle action.

How can I change this?

Comments

  • I'm pretty sure this is a well-known behaviour/limitation with Live's UserMapping.  When you switch to modMode and there isn't a mod present in that slot, the script doesn't deal with ANY of the controls that are being rerouted.  They are being forwarded directly to Live's inputs, the script isn't even able to see their input.


    What are you trying to assign them to?
  • I tried to assign them to some macros in an effect rack to enable some beat repeats, but I have also tested this on a mute switch on a track and it has the same behavior.


    I'm sure that I had them mapped before in 9.1.2 but seems that Abes id messing things up again for our workflow. I was on a good way building my new performance template, and had most things in place and now this happens, so I'm basically back to square one.


  • Hey Mike, 


    I just checked this out, and it's working correctly for me:  that is, if I go to an empty modSlot and UserMap one of the buttons to a mute, when I press the button it toggles the mute off, when I press it again it toggles it back on.  Is this not the behaviour that your expecting?  I checked in 9.12 and it behaves the same way there.....

    a

  • That is what I had working before, but for some reason it doesn't work anymore. I have the mapping for faders and knobs enabled and the top right encoder set for the banking.


    I also changed the remote script to use the lower left knobs on the global page as a third send, and what I realized wight his is that the volume fader is also disabled.

    The strange thing is that when I installed the original Livid script again, the problem was still there. I hope you can help me with this, because it must be something that I am overlooking.
  • Does it always happen, or is it intermittent?


  • It happens all the time, I tried resetting the remote script in the editor, I tried using the native livid script instead of mine, but it is all not working. Strange thing is that I had it working last week and this only occurred a few days ago, after I used the modified remote script and loaded a steppr. I then went to another empty mod and wanted to map some effects, and I realized that it didn't work, first I thought that it might be because the steppe is on the other mod, but it also happens without the steppr, because I tried all these things as well without opening any set, just opening live in default and tried to map something, but it stays on the momentary instead of toggle mode, really strange.


  •  I can't imagine the problem....it works as a toggle for me in every circumstance.....can you check with MIDI Monitor to see if perhaps the controller is sending out 2 events for each press?  I'm stumped on this one....


    a

  • it kind of looks like it, but what do I do about it?

    I guess it is something I have to do in the editor, but I have no clue at the moment.
  • I also reinstalled the remote scripts again and still there, but maybe I just have to install ableton again and then install the remote scripts again?


    I hate to all the work on the midi scripts again, but at least now I know where to do everything. Last modification I did was changing the left bottom knobs to a third send and the right faders to control the three return volumes.
  • I wouldn't bother reinstalling ableton or control scripts.....this is definitely something else weird going on, I think.  As I say, the remote script doesn't have anything to do with this behaivour, this is directly related to how Live deals with the data coming in.....the remote script is just telling live to "ignore itself" when you're in User Mode.  You should try some UserMapping without having the remote script installed, see if you get the same behaviour.


    Are you using IAC for anything?  Maybe there's a feedback loop?

    You can check to see what's going on by downloading MIDI Monitor and checking the messages that are being sent to Live from the controller:


  • Ah wait a minute there is an iac bus activated, Let me have a look.


  • Problem solved, I had the IAC bus on


    Would this mean that I cannot use the extra channels for hex now? I am still using the b994 hex as a mod in the cntrlr script

  • Just make sure the IAC is disabled for "Remote".....you can still use it for "Track" input and you shouldn't run into problems.

  • ok great, thanks for this, such a small thing but I would have been searching for days before I would have found it myself.


    Thanks buddy you saved me once again.
Sign In or Register to comment.