Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Twitter

Code ring LEDs don't work in Bitwig

edited May 2014 in Hardware

Hi

I've been having trouble with my Code's LED rings in Bitwig. They just don't change state once Bitwig is running.

But I finally found a temporary way to get them working...

If I reset the Code to default settings from within Livid Code Editor then the led rings respond ("walk") both when turning a knob on the controller and when turning a midi learned knob from within BW but if I close and restart Bitwig or remove the Code from the controller list in BW and re-add it they stop working... the knobs still function (i.e. they send messages) but the led stops "walking" both from the hardware and from turning a knob in BW.

It seems that I have to always have Livid Code Editor open and reset the Code to default settings every time I launch Bitwig from scratch... might be a Bitwig problem or a Code problem... hard to tell.

Anyone else getting this behaviour?

Tagged:

Comments

  • Have you tried saving your settings?  It sounds like you've reset to defaults (which is necessary), but haven't saved those settings to the controller, which is why it goes back to the old settings when you restart it.


    a

  • Hi Amounra

    Yes I've gone back and double checked, and indeed still the same problem despite saving it, then testing that it still works (which it does) and then restarting Bitwig to find it not working again.

    I've tried this with both the online editor and the downloaded one (Livid Code Editior v2.09)

    Also it works fine in Ableton (trial). Closing Bitwig doesn't fix the problem, i.e. the Code's LEDs still don't respond... but once it's closed I can then restart the Code and it works fine again until I restart Bitwig.

    In fact it does keep working when Bitwig is open(ing) right up to the point at which the message:

    "Codescript version 1.0 Loaded."

    appears in Bitwig. As soon as that message appears the LEDs stop "walking" when you turn a knob.

    I was worried it was something wrong with my Code not being able to save but the Ableton test dismisses this I think.

    Anyway sounds like a problem with Bitwig or 'Code.control.JS' which I understand you are working on...

    ...and somehow resetting to defaults in the editor permits a restart of Code without Bitwig knowing and so it doesn't attempt to reload the control script...

    So I'll wait for the next release! But is interesting nobody else is getting this? Not sure how many of us there are with Code+Bitwig?

    Cheers
    SL

  • Working on the script right now, I see what your problem is I think.  Local control gets turned off in the script, you can change this by commenting line 100, just add two slashes like this:


    //LOCAL_OFF();

    Let me know if that solves your issue.

    a

  • Did some more testing....that's not the problem, but when I figure out what is, I'll get back to you.....


    a
  • Ok, that IS the problem.  Just make sure to reboot your Code after you make the change and save it.


    a

  • SOLVED!

    Commenting out LOCAL_OFF(); works a treat.

    Thanks Amounra!

Sign In or Register to comment.