Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Twitter

Problem getting going with LividStep

edited April 2014 in Software Discussion

Hello, after setting up Lividstep I get led feedback to the buttons ohm controls.  The LEDS move left to right, but once lit, they say lit until i hit space bar.  Also when I buttons, the  track detects midi in ableton but nothing happens in the m4l device, the sequencer doesn't react at all and the LEDS don't react. I recently tried a bunch of monome emulating stuff and was trying this as I thought it would be simpler. I'm wondering if installing all those files for the monome emulators might be messing this up? 


Any suggestions?

Here is a screenshot  of what it looks like in ableton.

I am on max 5 and live 8.4. 
Thanks.
Tagged:

Comments

  • Hello, thanks for the reply.


    Long story short is that I got ohmmodes going, and it can work with Livid Drum Steppr, but not with lividstep. I'm really hoping to get an MLr style app going with OHMRGB and I feel like the problem I am having with livid step is reminding me of my problems with monomodular....  so if anyone knows why livid step, or molar when run in monomodular do not respond at all when I hit buttons, that might solve this whole huge issue.


    ohm modes...

    So I guess I go thrown off because  when I watched Livid+Step+Quicksetup-Mobile video I downloaded from Livids Vimeo Page, the video maker did not selected OhmModes in prefs. I also didn't see anything about using 'Ohm Modes on the Livid Step wiki.

    Another area of confusion is that the Lvid Step wiki says to enable track and remote for ohm controls.
    More confusion is that there is livid step, and also the OHM RGB steppers....

    I understand things can change alot over time with new versions of live, m4l etc coming out and I know maintaining  consitency on all these controller app tutorials over time is very very difficult. I didn't expect everything to work right away with controller apps by any means, I just wanted to explain my confusion in case that helps understand my moves. 

    Anyways, I installed Ohm Modes today.

    At first, Ohm modes like everything else I had tried on the OHM is acting  "messed up". The Nav L button was going right not left. Some activator buttons would work, some actually hit mutes, some don't work at all. 
    After a while of that I reinstalled Ohm Modes, (maybe it was ohm modes 2?) Then I checked the midi remote scripts folder and saw that Ohm Modes and Ohm Modes 2 were there. I deleted Ohm Modes and now Ohm Modes is  working correctly! Finally I was able to troubleshoot something successfully!!!


    Now that OhmModes is fixed, i Can hit the gary button and re set up livid step.....the problem is it is still acting like before, messed up in same way that when I hit buttons nothing happens, and that the LED feedback is messed up and the buttons run left to right but always stay lit untill I hit space bar.

    So i am still back at square one with livid step.

    Other info maybe to be used to troubleshoot....

    The screenshot from the Ohm Modes wiki has track and remote enabled on  "ohm 64 external" . In my live prefs, that is no longer an option. The only available ports are "Ohmmodes input (ohmRGB (Controls) or Ohm RGB port 2. The instructions in this thread were to disable track and remote so I did that, I'm just pointing this out because it might relate to my next issue. 

    To be honest I don't want to use the ohm modes really at all except if it is the only way to work with m4l patches. I have an apc and want to do clip launching with that. I just want to be able to run m4l sequencers or mlr apps and switch bettween. I know this is tough because there are so many  variables but if anyone knows how trouble shoot this please help! Any general advice on what to install and trouble shoot first would be good. And any knowledge about what works, and in conjunction with what. Thanks alot in advance.




Sign In or Register to comment.