Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Twitter

Ohm Classic Wood and OS X 10.9

edited December 2013 in Hardware

Hello, 


I got my hans on a perfect Livid OHM Classic Wood some time ago, and as long as I was using 10.8.5, everything worked fine.

But since the upgrade (yes, I know, why have I've not waited for someone else to try it out for me first), there is no MIDI over USB, and when I use MIDI port and connect trough the MIDI interface, i get only knob and faders but NO BUTTONS?! 
Interface seems not to receive any notes coming from the Ohm.

Now I've seen that the MIDI drivers have not been updated for this one, but it was not an issue in 10.8.5.

But why is the MIDI itself not working?

Is there any chance to save this nice piece of gear? Please?

Many thanks!
Tagged:

Comments

  • I'd try downloading the latest driver from FTDI. This is what was used in that product http://www.ftdichip.com/Drivers/VCP.htm

  • Got the same suggestion from the support, and it worked for the USB connectivity. The knobs an faders are all OK now, but still no MIDI or USB activity with the buttons (pads or anything else).


    I have opened it, and there is nothing unusual about it, except the fact that they seem really to believe in hot glue at Livid. It's all covered in it, but it is working, all wires seem ok and connected and nothing seems to move.
    No water damage or any sign of manipulation (well not prior to mine now...).

    So my last guess it is the Firmware or, in worst case scenario, failure of some HW controller for the pads and buttons.




Sign In or Register to comment.