Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Twitter

Enabling send mode or selecting a track arms record on the selected track

edited June 2013 in Hardware

Using Base with the Ableton Remote script:

Enabling send or device mode arms record on the selected track. Selecting track 4,5,6,7 or 8 arms record, too.

Peter
Tagged:

Comments

  • That's the auto-arm feature.  It will only do that on MIDI tracks, and its intention is to allow you to use the pads for playing through an instrument without the need to explicitly arm it.  


    You can turn the functionality off in the Map.py file contained in the script folder by changing:

    AUTO_ARM_SELECTED = True

    to false.  You'll need to restart Live afterwards in order for the change to take effect.
  • I want to turn this off, but my Map.py file doesn't have the AUTO_ARM_SELECTED text in it. Is there another Map.py file I should be using? Mine says it was created on 2014-7-26.

  • For what script?  Base?  If so, it's not something that the newer versions of the script use....it's all done inside Ableton, and has nothing to do with our implementation.  The AUTO_ARM_SELECTED flag was something used in our scripts before Live 9 was released, but Ableton added their own auto-arm mechanism.  I'm pretty sure you can defeat it by adding a line to your options.txt file.  Here's some info from the Abe's forum:



    Let me know if that doesn't work, I'll see what I can do to help you further.

    a

  • edited January 2016

    Well, yes, it's the Livid Base script. And I have modified Live's options.txt file to defeat this.


    But here's the thing: it works like I want as long as the Base script is not selected. As soon as I select the Base script again, the behaviour returns. Even if the Base hardware is disconnected, this happens. Selecting other scripts, such as the APC 40, does not cause this behavior. Logically, I suspect the Base script causing this behaviour.  
  • edited January 2016

    I'll double check and get back to you.....I'm pretty sure I pulled this functionality out of all the scripts for Live9 versions, maybe something else is going on though.


    a
  • Ok, right you are.  I can duplicate.


    To remedy, you can open up the Base.py script and comment line 812 so that it looks like this:

    #self._setup_autoarm()

    Restart Live and you should be good to go!

    a




  • That worked, thank you!


Sign In or Register to comment.