Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Twitter

CNTRL:R Firmware made things worse

edited January 2013 in Software Discussion

Hello, 

I have recently mapped the cntrl:r to vdmx and everything worked ok. I had note On and note off working from vdmx and was ready to go. After this I downloaded the firmware and installed it. Now the controller is acting weird. When i dim the lights off from the editor, the top right two leds remain lit, whenever I finnish and close vdmx some led remains lit for no reason at all and I have to unplug the usb cable tu turn it off, I can't get noteoff velocity (color) for my buttons when I go trough them to switch layers, as I used to do before the firmware. 

I really don't think I screwed the firmware upgrade, here is what I did:
got the controller on boot mode, 
I opened the program in windows
loaded the hex file into it
checked that little box - Allow Configuration Word Programming
hit the program/verify button. 
It completed succesfully.

So, what happened? everything was working fine, and now I get all those errors (that I know of).
Is there a non compatibility between the latest vdmx and the latest cntrl:r firmware that dosen't let me to send note off colour information to the buttons?
Those sliders are supposed to remain lit like that in the top right corner of the controller when dimming lights down to 0?
Did this happen to anybody, to close all the programs and to have one button still remaining on?

I would really apreciate some support on this. It was all working fine before the firmware.
Thanks


«1

Comments

  • edited January 2013

    Have you tried resetting to defaults with the CNTRL:R editor after the firmware update?  I'm exactly clear on your problem, but that is where I'd start.  Make sure to send and save after resetting.


    Also, can you turn on/off these individual offending buttons with the editor software?  

    There are two versions of firmware for the CNTRLR, one for plastic shafted encoders and one for metal shafted encoders.  Are you certain that you installed the right one?  Which version of the CNTRL:R do you have?

    a

  • Hey, 


    I had already inspected the editor button by button, just to test if everything interferes with, for example the first issue, ALTHOUGH it wasn't very clear to me from the start what that was. So, vdmx IS sending note-off (that's why those buttons switch on and off when I switch trough them, as I normaly want (to switch between layers), BUT the note-off velocity doesen't do anything any more. Before all this buttons had a background color in the off state, but now I just have the color of the one layer button that's on, so I think something screwed up the ability of vdmx or the controller to give back the note-off velocity. 

    Still, I am able to get this note-off color when I map individual buttons or in the media bin, so that's why it's odd, only because before the firmware, when setting the value in the note-off velocity, it worked and now it doesen't. 

    Now, as for the Firmware, I am not really shure if I installed the right version, because my english is not my first language and I think I interpreted SHAFT as the carcase of the midi. Which is black. Afterwards I searched for shaft and I realized that it's not the same thing, but I still don't know how to verify this. When I look underneath my buttons with the bare eye, everything underneeth the knobs seem to look like white aluminium (except the encoders which looks like black plastic), but is there another way for me to check this by the serial number or something? I'll look into that, because I installed the Black shaft firmware, and maybe it has something to do with it. 

    The controller was a gift and I did not look into the material tech specks, so yea...let's check that.

    (p.s) there's a little of color random abnormal color switching  when i check the midi thru in the editor, this happened when I just checked to see if something would make any difference, and I did reset and all that... if it helps..) 




  • Also, when I dim the lights all the way, the top right two knobs remain lit. I will  install the other (silver) firmware to see if it makes a difference. 



  • 1 Installed the silver shaft firmware. 

    2 Encoders got inverted.
    3 Didn't find any option for switching back in the editor menu (like for ohmrgb in the wiki)
    4 Did not see any difference in the behaviour of note off from vdmx.
    5.The upper right corner leds still remain on when dimming all lights.

    6 Installed back the black shaft firmware, encoders are right, but asside for the encoders working correctly, nothing changes. (still don't know if I have the silver shafts or the black shafts, but I'm assuming I have the silver ones since they look like that, which makes things even weirder)



  • 1. The first trouble is that when I am sending values from note range tab from VDMX, everything works except the NOTE VELOCITY value. Nothing happens when changing it, it doesn't change the color from the "off" buttons like it did before the firmware upgrade. 
    The noteoff velocity in the note tab works fine in note mode, for individual buttons, but not in note range. 
    In VDMX - media bin - there is an aditional tab of settings for clip trigger with the purpose of sending "ready", "playing", "off" information for the noteoff velocity, and that also works too, on any of the buttons I assign the clip to.

    2. When I un-assign something from a button or any combination of buttons, the button remains lit up and the only way it would switch off is to remove the board from the usb port, or reassign something different to it.

    I think a small part of the code inside the controller is acting weird or got screwed up, I really can't figure it out.

    I don't want to write this much on the forum, I only want to help you understand what's happening. 




  • Some weird "port2" appears in the popup menu list in the editor, it wasn't there before and I have not plugged anything new. 

  • regarding the knobs that won't switch off their light in the top right corner, they gently fade in and out when the computer is on sleep mode and the midi is still connected to the usb. 


    btw, I'm on Mid 2009 MacbookPro - OSX Lion. Clean install last week. 
  • Robert,

    You can carefully pull the encoders caps off to check the color of the shaft. From there I would download the correct firmware again from our site (black or silver). Then reload the firmware on your controller. After that do factory reset, send to brain, and save to brain.

    Let me know what happens, and we will go from there.


  • I tried to gently pull one off, but it's too sturdy and I'm afraid to break it, the product is still in warranty and I don't want to loose that. I didn't realize this was about the encoders only, cause from the way I look at them (from an angle) the shafts are black and that means I installed the right firmware. 


    Also, the other firmware (silver) inverted my encoders and in the editor there is no function for flipping them back. So, I am pretty sure this is the right one. 

    I did reload the firmware (if the reload is the same procedure as installing the firmware the first time without trashing settings or other stuff like that), and I am assuming that by "send to brain" and the "save to brain" you are reffering to the boxes in the editor - send and save.

    I did that many times before. I 'll do it again just for fun


  • Do I still need to be in boot mode when I'm in the editor resetting to factory settings and saving? 


  • no, just in regular mode.

  • did it. what should i look for? Still the same stuff with the two lit knobs and the noteoff velocity not working.  If it's easier, my skype is roberterdos.

  • So? Any further advice for making this controller work properly, please? I still cannot get note range - noteoff velocity from vdmx so far, no matter what value I introduce. What could the new firmware do to mess this up?

  • It might have something to do with the message that VDMX is sending (just a stab in the dark here...). The CNTRL:R responds to NOTEON message velocity....NOTEOFF is a different message.  I'm not sure how the CNTRL:R responds to NOTEOFF messages and I don't have any hardware in front of me to check, but I'm guessing this is the problem.


    a

  • The thing is that it responds very well if I map every button individually. It asks for a noteoff velocity number to set the color. The same with the special UI inspector in the media bin, where it  automatically maps every trigger clip to an on and off led value and even ready and playing options are mappable. But for some reason, the note range (which i use for switching trough pages) doesen't transmit the note off  velocity to the midi controller.  

  • And it did before the firmware update.

  • If you haven't already, I'd highly recommend downloading "MIDI Monitor" and taking a look at the messages coming from VDMX just to confirm that it is sending the messages you think it is.  If you could confirm exactly what messages are being sent to the CNTRL:R that it's not responding to, we have a better chance of chasing down the problem.


    Here's a link:

  • Ok, I mapped 4 buttons to switch between layers, so the CNTRL:R lights are working with the value of 122 - yellow, but the note off velocity - with the value of 15 is not showing on my controller, the buttons remain unlit. 



    thanks for the link, amounra
  • I pressed all 4 buttons consecutively 


  • I also used the midi spy in the controller editor software and did the same thing. I got this:

    http://picturepush.com/public/12028243


    It seems like the values are not correct here..
  • edited January 2013

    That's because the value of 15 is being sent to the CNTRLR as a "NOTEOFF" value.  It's not the same thing as a NOTEON value, they are different messages.


    Thanks for the screenpic, btw, that helps a lot!
  • But shouldn't that be right? I mean if you look in the first picture I have the "send note off" box checked in vdmx so I can have two colors as feedback on my controller, the layer that is on and the layers that aren't on (but they are lit in the "off" color - which would be 15 in this case. I don't know what to do from this point on to fix it.

  • http://picturepush.com/public/12028393


    I also assigned a SINGLE button in the same manner, but you will see now I am working in the NOTE tab in VDMX (not the note range tab) and the led actually lights up both ways. (green and blue for on and off) 

    I pressed it four times ON/OFF
  • Theoretically, yes.  But since the CNTRLR isn't designed to respond to NOTEOFFS in the way you're (or VDMX) is expecting it to, it's not going to work that way.  Perhaps you could reassign the CNTRL:R to use CC's instead, do you have the same options available on the CC's page in VDMX?

  • @ second post:  Right, if you look in MIDI Monitor's window, you see that the NOTEOFFS are velocity 0.  The CNTRL:R is responding to the NOTEONS, which are telling it which colors to change.  NOTEOFFS are always (presumably, again I don't have hardware to check this with at my disposal right now) going to turn OFF the button, whereas NOTEONS are going to turn the button LED on, and tell it what color the LED is.



  • Yes, I got it. 

    It looks pretty simple, but what troubles me is that it worked before, yesterday prior to installing the new firmware. So there must be a way to do it. I would really like to know what should I do to make it work, this is huge for a midi controller and for my workflow, I often link stuff together like layers and pages and effects chains. 

    I don't know how to try the cc switch. From the editor or vdmx? Can you lead me a few theoretical steps? At least to have something to do till you find a controller to take a look at. 

    Thanks a lot for the support, I appreciate, I have been talking to myself here almost the entire day :)


  • Also, is there a way to downgrade to the earlier firmware? It seemed to work better for me, since ..you know.. it worked. 

  • Yeah, I know where you're coming from....it's a silly incompatibility.  The problem these days is that RGB/colored button controller's are an emerging technology, and there hasn't necessarily been a standard developed.  When I started writing software for this stuff like 4 years ago it was even worse.  


    Anyway, hopefully we can get you straightened around somehow....

    I'm trying to get a copy of VDMX so I can play with this and see what's going on exactly, but currently I'm flying blind because I've never used it.

    If you can post me a screenshot of the last tab of that UI Inspector for the pop-upbutton, the one labeled "Cntrl" (next to "Note" and "Note Range") I might be able to help you with reassigning things to CC's with the control surface.  Basically, you'd need to use settings on that tab after you'd changed the CTLR:R's buttons to send CC's via the Livid Editor.

    It's hard to say why it worked before....but it's also hard to point you to an earlier firmware version, since we don't know what version you had installed to start with.

    I'll do some checking...unfortunately the majority of our team is on their way to NAMM right now, so my resources are limited at the moment.  

    Cheers :)
  • http://picturepush.com/host.php?image=12029155


    The ctrl tab here is too poor I think, but there are other options in vdmx range note tab or even when assigning the controller to vdmx. 
    Livid encoder is a little poor comparing to the livid code editor or something where you can reassign or convet values, and the only cc options that I am aware of are on the encoders of CNTRL:R which are not really that fun to use as switchers in real life. If there is another way I will be excited to hear about it. I am wondering if all cntrl:r controllers act this way, or I just broke mine. I will ask the vdmx support team too about this, meanwhile you can download VDMX demo from here. 


    Thank you again for your interest.
  • I'll have a look when I have access to my CNTRL:R and get back to you.

Sign In or Register to comment.